Wow! was I stupid today

Ristin

Seaman
Joined
Aug 4, 2017
Messages
58
Yay, our 19 month long winter is finally over and it was time to summerize the boat.
Placed the battery in the boat and proceeded to connect the leads. Positive first then negative and a big burst of sparks, huh, that's odd there shouldn't be anything active to cause sparks especially a big burst like that. Well, ok, battery cover on and secured hit the switch to raise the drive and nothing happened. Turned on ignition switch and nothing;what in the world....? Hmmmm what could it be....oh, umm I didn't actually look at the battery terminals when I connected the leads. Yup, connected the battery backwards, fortunately the electrical system is idiot resistant and the Buss AGU-50 fuse blew protecting my boat from my inattention. 30 minutes and $5 later a new fuse had the boat purring like a fat kitten next to a gallon of spilled milk.
 

robert graham

Admiral
Joined
Apr 16, 2009
Messages
6,908
I did that....once! I expect most folks have done that or worse, wheather they admit it or not!
 

southkogs

Moderator
Staff member
Joined
Jul 7, 2010
Messages
14,825
Almost fried a system that way myself once ... two types: those who have and those who will. ;)
 

dwco5051

Commander
Joined
Sep 14, 2008
Messages
2,367
More than once. The most it ever cost me so far was the master relay for a Toyota pickup.
 

JBinVA

Cadet
Joined
May 2, 2018
Messages
14
Done it once when I was a kid and thought I burned out my dad's boat. Been obsessive compulsive about battery terminals ever since.
 
Top