Volvo Penta 5.0GL - occasional stumble at take off - continues through rpm band

Augoose

Lieutenant Junior Grade
Joined
Mar 21, 2010
Messages
1,158
All,
my 1999 VP 5.0GL is experiencing an occasional stumble at take off. Almost sounds like one of the cylinders not firing. If I continue to hold the throttle position, it will continue to stumble. If I increase throttle, it seems to work its way through the stumble but takes up to 20-30 seconds. If I back down to idle and then apply the throttle again, it runs perfectly. Idle is great, revs out of gear fine, and 9 times out of 10, it has a great hole shot pulling skiers, etc. When it doesn't stumble, the boat appears to run fine all the way through the rpm range.
This stumble is what I believe caused a hydro lock a few weeks ago (written up in another thread). That time the engine died as the idle was set a bit too low.
Today I pulled a skier about 15 times. Only once it stumbled. When it stumbled, I backed down the throttle to idle and then immediately increased throttle again and brought the boat back to the trailer - ran fine the whole time back.
About 6-7 years ago (about 175 hours ago) I put on a new coil, new plugs, new dizzy, new spark plug cables, and I rebuilt the carb.
My plan is to inspect the dizzy, plugs, cables and coil for poor connections. I also suspect my alternator as well, possibly the feed to the fuel pump is having issues, but I wouldn't expect the boat to be able to immediately recover following a stumble if the fuel pump was having issues - if the pump failed and I ran the fuel bowl dry, I can't see it immediately recovering after letting off the throttle for just a second?
Everything points to electrical (at least in my head) but I can't point my finger at any one component at the moment because the symptoms are intermittent.
Thanks for the help!
 

alldodge

Supreme Mariner
Joined
Mar 8, 2009
Messages
31,251
My guess is weak fuel pump or bad connection/relay to the pump
 

QBhoy

Rear Admiral
Joined
Mar 10, 2016
Messages
4,710
Could be a load of things but if I was to guess at a few...

crack in the diz cap or from tightening down
2nd choke flaps being lazy or intermittent
auto choke sticking
poor earth
 

Saline Marina

Petty Officer 2nd Class
Joined
Sep 9, 2014
Messages
162
It seems like its not an ignition issue. If it was I would expect worse performance the more you opened the throttle because of the increased resistance to jumping the gap as the combustion pressure increases. That can lead to the spark finding a pathway of lower resistance that's not thru the combustion chamber.

I would focus on fuel issues first but the distributor cap + rotor is very fast to check out.
 

Augoose

Lieutenant Junior Grade
Joined
Mar 21, 2010
Messages
1,158
Anyone provide opinions on the condition of the distributor and rotor? Thanks!
Click image for larger version  Name:	Distributor.jpg Views:	4 Size:	1.49 MB ID:	10807927Click image for larger version  Name:	Rotor.jpg Views:	4 Size:	790.7 KB ID:	10807929
 

Attachments

  • Distributor.jpg
    Distributor.jpg
    1.5 MB · Views: 0
  • Distributor.jpg
    Distributor.jpg
    1.5 MB · Views: 0
  • Distributor.jpg
    Distributor.jpg
    1.5 MB · Views: 0
  • Rotor.jpg
    Rotor.jpg
    790.7 KB · Views: 0
  • Rotor.jpg
    Rotor.jpg
    790.7 KB · Views: 0
  • Rotor.jpg
    Rotor.jpg
    790.7 KB · Views: 0

alldodge

Supreme Mariner
Joined
Mar 8, 2009
Messages
31,251
Have seen better and worst, does need cleaned up and couple new parts
 

Augoose

Lieutenant Junior Grade
Joined
Mar 21, 2010
Messages
1,158
Thanks Alldodge. What new parts - ignition module, cap and rotor?
I checked the coil and the resistance readings are within spec - however I'm wondering if it fails as it heats up?
Based on the condition of the ignition module I'm hoping that's the issue?
 
Last edited:

alldodge

Supreme Mariner
Joined
Mar 8, 2009
Messages
31,251
I would do cap and rotor, remove the pickup coil and clean it. Take a soft wire brush to the reluctor wheel and re-install pickup.

It may be the distributor, but the throttle down and then back up makes me think fuel.
 

Lou C

Admiral
Joined
Nov 10, 2002
Messages
6,813
The cap and rotor actually look good to me but the module has a fair amount of corrosion; how do the connections to it look?
one more data point: I’ve averaged 6 years between carb cleaning and rebuilds with the Quadrajet on my engine, you said the last time you did it was 6 years ago. It might be time again...
 
Top