75 stinger running weird

HemiRam

Recruit
Joined
Sep 1, 2008
Messages
2
Hey guys, I'm new to the boating world so bare with me.

My dad is having problems with his 75 stinger. Its runs great out of water, but when its in the water it will stall out when you try to put it in gear. If i adjust the idle to where it will not stall, it slamms into gear hard. Seems like its flooding itself out, cause when you play with the throttle (on-off-on-off) you can get it to move. It runs great in the higher RPMS. Boat gets to about 40 MPH. The boats Tach is not working, I just installed a new Recifier??? (Spelling) and its still not working. The previous owner may have it wired wrong. any links to wiring a tach??

And lastly, when you are slowing down and want to idle...the RPMS will RACE really high, and you have to shut it down, and start it back up for it to idle normally, but if it idles too long, it will rev high again.

Thanks Guys
Ed
 

Silvertip

Supreme Mariner
Joined
Sep 22, 2003
Messages
28,770
Re: 75 stinger running weird

You have a linkage problem on the engine and you really need a service manual to set things up. Fiddling with the idle speed is not the problem. Apparently the timing advance or throttle linkage is binding.
 

HemiRam

Recruit
Joined
Sep 1, 2008
Messages
2
Re: 75 stinger running weird

Nope, all linkage is tight and returning correctly. what can you spray around 2 strokes to check for air leaks? I thought it was starting fluid but that just could be for 4 strokes.
 
Top