Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse
No announcement yet.

88 4.3 Mercruiser won't go over 2500 RPM under load

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 88 4.3 Mercruiser won't go over 2500 RPM under load

    Good Morning everyone. I recently purchased a 1988 Mark Twain super clean boat. Has a 4.3 Mercruiser in it. Got it on the water last weekend and would only go about 3200 RPM max barely planed out, running rough then eventually died running rough. Brought it home and did the following to it.

    1. Spark Plugs
    2. Cap and Rotor
    3. Wires
    4. Water Pump, it was making noise
    5. Fuel Water Separator filter

    I bought a carb rebuild kit but felt the running problem was ignition related. After installing all the parts I timed it to 8 deg. starts right up and idles good, revs in neutral well. So we got it back on the water yesterday and it will not go over 3,000 RPM sounds like its laboring, no more opting, spitting, or dying anymore, runs good but under load has no power won't plane out won't go over about 8 mph, super dog.

    So we got it back home checked timing again, we even adjusted it on the water manually did not make a difference trying to manually advance it while running. So now we are left with three options

    1. Carb problem but does not seem like a carb problem. It has a electric fuel pump installed
    2. Exhaust plugged
    3. Poor compression

    We pulled the passengers manifolds yesterday looking at the flap and manifold didn't see anything still need to pull the driver side to see if flap is OK. I am hoping its in the exhaust.

    The way it runs I have a hard time believing compression is a problem, but once I get both manifolds off I will check this maybe today.

    Don't feel its carb problem, carb seems to be dumping fuel when running under load but just seems bogged down.

    Anyone have any thoughts on this. Some other technical info. 1.84 outdrive gear ratio, 19 pitch prop.

    Any ideas would be great, thanks.

    Also having some weird electrical problems with gauges that I will post about after this but gauges flutter constantly when key on with fuel pump so I isolated pump with relay and its better but still flutter, gas gauges needled is all over the place doesn't to sit still if you think this could be related

    Thanks everyone

  • #2
    Do a compression test
    What pitch prop?
    With gauges bouncing around check your grounds, clean them
    94 Formula 27PC Custom 509MPI MEFI3 , B3 XR
    95 Rinker 232 w/ 7.4L Carb 0F425011 B1 0F486471
    07 Seadoo GTX
    Merc Adults Only VP Adults Only
    G-Dad always said "First Liar doesn't stand a chance"

    Comment


    • #3
      Originally posted by AllDodge View Post
      Do a compression test
      What pitch prop?
      With gauges bouncing around check your grounds, clean them
      I am going to do compresion test tomorrow. Pitch is a 14.5 prop by 19
      I re did all the grounds that I can find and didn't change it at all. I am thinking possible Alternator seems more of a power fluctuation than a ground problem.

      Thanks

      Comment


      • #4
        check your plug wires. Sometimes they can be out of order but still run smooth without power
        1961 Custom Craft Sea Ray- 1964 Mercury 650. In family since new.

        Comment


        • #5
          There is an I/O- Inboard Mercruiser forum where you may get better responses to your questions....see below.
          If you are new to boating or have a new boat, a knowledgeable friend could show you how to operate your boat and save you a lot of grief, maybe some money, and maybe your life.

          Comment


          • #6
            Originally posted by Texasmark View Post
            There is an I/O- Inboard Mercruiser forum where you may get better responses to your questions....see below.
            Good point, GA_Boater can you move please
            94 Formula 27PC Custom 509MPI MEFI3 , B3 XR
            95 Rinker 232 w/ 7.4L Carb 0F425011 B1 0F486471
            07 Seadoo GTX
            Merc Adults Only VP Adults Only
            G-Dad always said "First Liar doesn't stand a chance"

            Comment


            • #7
              Done. Tanks again, AD
              BOAT SPECS FORUM HELP STARCRAFT FORUM SHOP iboats
              Please, no PM's (Private Messages) regarding boat/engine problems.
              That is what the forums are for.
              Only forum/moderator issues will be answered in PM's.

              Comment


              • #8
                Gentlemen, thanks I thought I had posted it in the MerCruiser thread, sorry. So as an update did an compression test all 145-155, cold, both flaps open moving free, no exhaust restrictions. so its back to ignition not advancing or carb issues. Have a carb rebuild kit I am going to take it off this week and do that while I put manifolds back on and then I can test timing again for advance and total timing etc.

                Thanks for all your help. Matt167, I have checked them several times and they are all good
                Keith

                Comment


                • #9
                  Sign up today
                  I would support the need to do a carb rebuild. Pay special attention to float height. Make sure you got every passageway clean.
                  17 Foot '90 Bluewater
                  Alpha 1 3.0 Merc - repowered in 2016
                  now - 4.3L Vortec - Alpha 1 GenII
                  Honda BF100L kicker
                  Engine custom - Transom 0D65328 - Drive 0D648864
                  If you ain't fishin, then yer working too much.

                  Comment

                  Working...
                  X