Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse
No announcement yet.

iBoats forum keeps wanting me to update my browser (even though it is current)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • iBoats forum keeps wanting me to update my browser (even though it is current)

    Just now, after logging into the forums, instead of being directed to the main forum page, I was presented with a splash screen asking me to update Firefox by clicking a button. This has happened once or twice before (on a different machine), and both times I just ignored it and re-clicked on my bookmark link to the forums. Today, however, it really surprised because I know my browser recently updated. (I also just now checked and I do have the current version for Win10.)

    What I find really odd about this is that, even though I was presented with a splash screen that looked like a Mozilla prompt, the URL was still that of the iboats forum. Even more unusual, this prompt was not presented upon startup of Firefox, which is when the browser normally would prompt an update; instead, it occurred after I was already on the site and after I had to login. It has never happened when visiting any other sites, only iboats.

    Has anyone else seen this? I have no idea what's going on, but this kind of behavior always makes me think of some sort of malware redirect. Any ideas?

    Location: West Central Illinois, USA 1997 Larson 186 SEi Bowrider I/O Mercruiser 350 #0F747565 Mag Alpha One Gen II #1A270120 Transom and Deck Restoration Project on my '97 Larson Bowrider

  • #2
    colonel_sanders

    I believe the dev team asked the MODs about this a couple of days ago. I'm flagging this so they can take a look.

    Comment


    • #3
      JASinIL2006

      What ever you do, don't click on the Update button. It will download a Zip file and if you unpack the file it will install malware. I've got it for both Firefox and Chrome when both up to date.

      This is one of the things support is trying to erase from the software and may be be a source for some of the troubles we're seeing. It's a tricky SOB, S-O-B or S.O.B., whatever you prefer.
      BOAT SPECS | FORUM HELP | STARCRAFT FORUM | SHOP iBoats
      Please, no PM's (Private Messages) regarding boat/engine problems.
      That is what the forums are for.
      Only forum/moderator issues will be answered in PM's.

      Comment


      • #4
        Thanks, that is precisely what I was concerned about. I haven't and won't download it, but it is very convincing-looking.
        Location: West Central Illinois, USA 1997 Larson 186 SEi Bowrider I/O Mercruiser 350 #0F747565 Mag Alpha One Gen II #1A270120 Transom and Deck Restoration Project on my '97 Larson Bowrider

        Comment


        • #5
          Sign up today
          I know. It looks real and that's the shame!
          BOAT SPECS | FORUM HELP | STARCRAFT FORUM | SHOP iBoats
          Please, no PM's (Private Messages) regarding boat/engine problems.
          That is what the forums are for.
          Only forum/moderator issues will be answered in PM's.

          Comment

          Working...
          X