Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse
No announcement yet.

1974 Mercury Thunderbolt 7.5 hp , switch box test , wiring?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1974 Mercury Thunderbolt 7.5 hp , switch box test , wiring?

    Hi everyone, I have this motor with the Thunderbolt Ignition system, have tested coils,stator,coil wiring,all passed testing, bypassed kill switch to ground and still no spark. Does anyone have a diagram for the wiring to and from the switchbox, and how to test it?

    Thanks, Walt

    EDIT: Got the wiring diagram, how to test switchbox on non running engine?Click image for larger version

Name:	merc switchbox.jpg
Views:	1
Size:	84.6 KB
ID:	7181682

  • #2
    Re: 1974 Mercury Thunderbolt 7.5 hp , switch box test , wiring?

    It must be done with a DVA testing voltage in and voltage out, with 1 person testing and 1 person cranking

    Comment


    • #3
      Re: 1974 Mercury Thunderbolt 7.5 hp , switch box test , wiring?

      Your engine is a ground off engine and will not have spark with the orange wire grounded

      Comment


      • #4
        Re: 1974 Mercury Thunderbolt 7.5 hp , switch box test , wiring?

        Originally posted by Laddies View Post
        Your engine is a ground off engine and will not have spark with the orange wire grounded
        The orange wire from the switchbox fed to the yellow wire from the stator screw terminal, the wire for the kill switch was attached here. So to bypass the kill switch take the orange at the kill switch off?

        Took the switch box off, and get readings of .542 , and .560 in diode mode , testing the coil feeds of green - green/white , and brown (black?) - green white. The trigger feeds from the switchbox are reading at 1.267 in diode mode , the feeds from the trigger itself is zero?

        When connected reading ohms in the 2k range , the yellow wire on the screw block from the stator reads 1.767, when pulling the engine i get a voltage of between 8 and 10 volts .

        Are any of these in spec? Thanks, Walt

        Comment


        • #5
          Re: 1974 Mercury Thunderbolt 7.5 hp , switch box test , wiring?

          I posted a test for the system on your first thread read it

          Comment


          • #6
            Re: 1974 Mercury Thunderbolt 7.5 hp , switch box test , wiring?

            Originally posted by Laddies View Post
            I posted a test for the system on your first thread read it
            Got that , thanks. No information on the stator output voltage when cranking the engine. I get between 8 and 10 volts is this within normal limits?

            Comment


            • #7
              Re: 1974 Mercury Thunderbolt 7.5 hp , switch box test , wiring?

              If your using a DVA, no

              Comment


              • #8
                Sign up today
                Re: 1974 Mercury Thunderbolt 7.5 hp , switch box test , wiring?

                Originally posted by Laddies View Post
                If your using a DVA, no
                Found a CDI unit locally, put it in and spark has returned. Thanks for the help.

                Comment

                Working...
                X