Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse
No announcement yet.

1975 Mercury 1150...no power over 2000 RPM, starts and idles great...please comment

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1975 Mercury 1150...no power over 2000 RPM, starts and idles great...please comment

    Hi All,

    I have a 1975 Mercury 1150 (distributor) that was running great. I was away from lake for about 2 weeks and upon return I find the motor bogs down and won't make over 2000 RPM even though it starts and idles great and will run along all day below 2000 RPM.

    The carbs were cleaned back in July and I also did a full lync and sync at that time. Compression was great and even across all cylinders then as well. Fuel is new and bulb stays hard under acceleration. I put in new spark plugs and am getting spark to all plugs at idle.

    What should I be thinking? When I shut her down two weeks ago all was great, now this. Can a powerpack be the problem and can that "just go" while sitting?

    Please let me know what/how I can check next?

    Thanks,
    Darren

  • #2
    Re: 1975 Mercury 1150...no power over 2000 RPM, starts and idles great...please comme

    Sounds like the same thing that was happening to me with my small 10 hp. I took the float bowl off of the carb and found a VERY SMALL piece of something that was apparently interfering with the high speed jet fuel flow. IT would run fine as long as I had the choke/primer engaged but once off it would die. Would troll all day long with no problems. Worth checking out on yours even though the carbs were just cleaned. Something used to clean them may be inadvertently restricting the intakes or ports. Just a thought.

    Comment


    • #3
      Re: 1975 Mercury 1150...no power over 2000 RPM, starts and idles great...please comme

      Thanks for the reply RG2. I could see it being a carb issue if I only had one carb, but I have three of them, and although I'm not sure, I think it unlikely that two or three would have all high speed jets clog at same time and I'm not sure if clogging only one would cause such a consistent problem. It feels like it might be electrical related...not sure if a distributor can become faulty and not allow max spark advance? I see the distributor rotate but it feels like something just isn't firing.

      Comment


      • #4
        Re: 1975 Mercury 1150...no power over 2000 RPM, starts and idles great...please comme

        On a distributor model firing issues are they either work or they dont.I would check to see if the carbs are opening up all the way.Usually the bulb wont stay hard when running but the bulb wont go completly flat either.Make sure your tank vent is open and no air leaks in the lines.I am leaning more towards a fuel issue.Like I said the ignition system you have (1 switchbox and a distributor/trigger) either work or there dead.Look at your spark plugs wet/dry?????
        sigpic

        Comment


        • #5
          Re: 1975 Mercury 1150...no power over 2000 RPM, starts and idles great...please comme

          Hi Gomer,

          Thanks for the reply. I switched out my fuel tank, had my wife prime bulb while trying to accelerate but it was full and hard. I checked the valves and the connection is intact and all 3 open fully. Could it possibly be my fuel pump then? Maybe its just getting enough to idle and run at low rpm but not pumping enough for WOT? when I checked plugs the 3 rd down from top as somewhat dry and in thinking on it perhaps the others were not as wet as they could have been.

          Thoughts?

          Thanks,
          Darren

          Comment


          • #6
            Re: 1975 Mercury 1150...no power over 2000 RPM, starts and idles great...please comme

            If your spark plugs are dry/no oil,gas is a good sign your not getting enough fuel.On your carbs. if you have the backdraft ones behind the fuel inlet on each carb is a small screen that could be clogged or of course your fuel pump..
            sigpic

            Comment


            • #7
              Re: 1975 Mercury 1150...no power over 2000 RPM, starts and idles great...please comme

              Disconnect the fuel hose to the carbs, squeeze the primer and watch the flow, it should be as strong as your squeeze.

              Now crank the motor and watch the pulsed flow from the fuel pump, is it a good strong flow or a weak dribble?

              Comment


              • #8
                Re: 1975 Mercury 1150...no power over 2000 RPM, starts and idles great...please comme

                Thanks for the reply guys. I wont be able to check things again till I'm back at cottage in 2 weeks. Ordered the fuel pump rebuild kit just in case, might as well do that anyways and will check on the screen at the carbs as Gomer suggests since I don't remember it from my carb rebuild although I have the backdraft carbs. Will keep you posted and thanks for the assistance!

                Darren

                Comment


                • #9
                  Re: 1975 Mercury 1150...no power over 2000 RPM, starts and idles great...please comme

                  Darren, Did you happen to change the prop? A prop with too much pitch will cause the issue you are having. In addition, the idle circuit can contribute to the issue, if it is set too lean. Did you mess with it?

                  Comment


                  • #10
                    Re: 1975 Mercury 1150...no power over 2000 RPM, starts and idles great...please comme

                    Hi Chris,

                    No, didn't change a thing. I am running a 21P and when I put the boat to bed for the week it had been running beautifully, idles perfectly at 800rpm or so, 47mph at 5200 RPM WOT, pulls up my fat *** on a slalom ski, (like that for several weeks since I rebuilt carbs, propped down from a 23P and did a linc and sync.) then I show up at the cottage a week later and all of a sudden this problem happens. I am wondering (hoping) if it could have been a case where the fuel pump diaphragm just failed suddenly otherwise I cant account for such a sudden change. I won't get back up there until next week but I have my fuel pump rebuild kit ready to go.

                    Comment


                    • #11
                      Re: 1975 Mercury 1150...no power over 2000 RPM, starts and idles great...please comme

                      If the fuel pump diaghram failed, raw fuel would be getting into the crankcase. That does not sound lik your issue. I think it is clogged carbs. A single clogged carb can cause your issue. You can richen the idle mixture 1/8 turn and see if the acceleration will return.

                      I would remove the hex plug at the base of each carb and give the high speed jet a blast of gumout. If that doesn't fix it (it likely will not), it it time to clean the idle jets. You can try some gumout jet spray in the idle passages located in carb throat. The may fix it. The next idea is to remove the brass plug over the idle restrictor tube and give it a blast. Then tear the carb down...

                      Comment


                      • #12
                        Re: 1975 Mercury 1150...no power over 2000 RPM, starts and idles great...please comme

                        I was really hoping it wasn't the carbs as pulling these things is such a pain in the butt and I only just tore them all down a month ago! So it really is possible that one plugged carb could limit me to only 2000rpm? Since my number 3 plug seemed dry perhaps I should start with the middle carb first? That would be the correct one for 3 and 4 yes?

                        Darren

                        Comment


                        • #13
                          Re: 1975 Mercury 1150...no power over 2000 RPM, starts and idles great...please comme

                          Take a compression test, to make sure you didn't ruin anything internal. It will take 5 min and rule out serious issues. Distributor is advancing to max spark advance? Carbs are open all the way when max spark advance is reached?

                          Comment


                          • #14
                            Re: 1975 Mercury 1150...no power over 2000 RPM, starts and idles great...please comme

                            Are you running a metal or plastic tank ? It does not take much crap in the tank to get sucked up into the carb.A GOOD aftermarket in line fuel filter would eliminate this problem in the future,if that is the root of your problem
                            Cool Runnings,,, Mr.88

                            Comment


                            • #15
                              Sign up today
                              Re: 1975 Mercury 1150...no power over 2000 RPM, starts and idles great...please comme

                              I will be doing the compression test to be sure, just didn't have my gauge there last time but it does start immediately, idles smoothly all day long in and out of gear and runs fine up to 2000 RPM so I'm hoping its fuel related. I have new plastic tanks (6 gal) and an inline fuel filter since I rebuilt the carbs in June. I also verified that distributor is rotating to max and all three carbs fully open. Its just very strange that it was running perfectly when I left the cottage one weekend and then this problem happens when I got back the next week....didn't even run it up, just idled for a while, ran slow for a bit and then tried to throttle up and this problem occurs.

                              Comment

                              Working...
                              X