Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse

Help Tip: If you have a question that has not been answered to your satisfaction in the archives, it is always best to start a new thread of your own. By starting your own thread, you will receive the maximum number of views by forum members.

Please note this topic has been inactive for 90 days. For the best results, please start a new topic.

Thank you all in advance for doing your part in helping iboats run a smooth ship.

Additional forum rules linked below.
http://forums.iboats.com/forum-rules-guidelines-405/
See more
See less

4.3L V6 Mercruiser Stern Drive...HELP!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 4.3L V6 Mercruiser Stern Drive...HELP!

    Hi,
    Changed the main wiring harness on my mercruiser and have power to the circuit breaker, but nothing coming out of it. Could it be a bad breaker? Is there a way to test it? I think I have everything wired correctly??

  • #2
    Re: 4.3L V6 Mercruiser Stern Drive...HELP!

    Year? Model? EFI, Carbed, Drive, lots of different harness options.
    have power to the circuit breaker, but nothing coming out of it. Could it be a bad breaker?
    Yes, it could be the breaker.
    Don S.


    Please, no PM's (Private Messages) regarding boat/engine problems.
    That is what the forums are for.
    Only forum/moderator issues will be answered in PM's.

    Comment


    • #3
      Re: 4.3L V6 Mercruiser Stern Drive...HELP!

      1993 Sea Ray 4.3L V6 Mercruiser
      Carbed - yes
      don't know what your other questions mean?

      Comment


      • #4
        Re: 4.3L V6 Mercruiser Stern Drive...HELP!

        Is there a way to test the breaker?

        Comment


        • #5
          Re: 4.3L V6 Mercruiser Stern Drive...HELP!

          Originally posted by coroname View Post
          Is there a way to test the breaker?
          Disconnect the red/purple wire from the breaker. push the reset button. If there is no power to the empty terminal, then the breaker is bad.
          Don S.


          Please, no PM's (Private Messages) regarding boat/engine problems.
          That is what the forums are for.
          Only forum/moderator issues will be answered in PM's.

          Comment


          • #6
            Re: 4.3L V6 Mercruiser Stern Drive...HELP!

            Thanks Don - followed your steps and we have power to the empty terminal. Tried again to reconnect and test, seems to be grounding out somewhere? Any suggestions? Also, no power to the electrical panal at front of boat??

            Comment


            • #7
              Re: 4.3L V6 Mercruiser Stern Drive...HELP!

              Sounds like you have a short that is popping your breaker.
              Disconnect the main harness plug (the round one) on your engine and see if it still pops the breaker.
              Don S.


              Please, no PM's (Private Messages) regarding boat/engine problems.
              That is what the forums are for.
              Only forum/moderator issues will be answered in PM's.

              Comment


              • #8
                Re: 4.3L V6 Mercruiser Stern Drive...HELP!

                Yes - still pops the breaker

                Comment


                • #9
                  Re: 4.3L V6 Mercruiser Stern Drive...HELP!

                  You may have a short in your wiring harness on the engine. Have any work or repairs been done to the engine lately, and I mean any repairs?
                  Don S.


                  Please, no PM's (Private Messages) regarding boat/engine problems.
                  That is what the forums are for.
                  Only forum/moderator issues will be answered in PM's.

                  Comment


                  • #10
                    Re: 4.3L V6 Mercruiser Stern Drive...HELP!

                    Changed the main wiring harness on my mercruiser. Yes - still pops the breaker
                    Ayuh,....

                    In that case,.... You Screwed Up the installation of the New Harness.....
                    Now,...
                    You've can only go thru it,+ Find the screw up......

                    Comment


                    • #11
                      Re: 4.3L V6 Mercruiser Stern Drive...HELP!

                      Changed the main wiring harness on my mercruiser and have power to the circuit breaker, but nothing coming out of it.
                      How the ............. did I miss that.

                      Duh


                      Like Bondo said, you have it installed wrong.
                      Don S.


                      Please, no PM's (Private Messages) regarding boat/engine problems.
                      That is what the forums are for.
                      Only forum/moderator issues will be answered in PM's.

                      Comment


                      • #12
                        Re: 4.3L V6 Mercruiser Stern Drive...HELP!

                        BINGO!
                        Thanks for your support and advise. Had the alternator wires swapped. Changed them, and works like a charm! (knock on wood! the real test will be this weekend)

                        Comment


                        • #13
                          Sign up today
                          Re: 4.3L V6 Mercruiser Stern Drive...HELP!

                          Who is this fake Bondo that was correct?

                          Comment

                          Working...
                          X