Electrical Issues

ErieTom99

Recruit
Joined
Jul 26, 2022
Messages
5
Hi All,

Sorry in advance, this is a long one....... 2007 Rinker 250. Everything with the boat was working top notch until this season. I had the marina install 2 new batteries before launch. Old batteries were pretty old and didn't hold charge well. Everything electrical worked fine on the old batteries.......Now this year, only after they installed the new batteries, there are all sorts of weird things happening.....

Weird thing #1, the volt meter on the shore power panel doesn't work. Shore power works fine, battery charger, tv, ac, etc. all work just fine. The voltmeter just didn't read anything when I got the boat in the water for the first time. Even odder, last time we were up there, I put the boat on battery 2 and now it reads just fine when shore power is connected!

Weird thing #2, the GPS at the help will NOT turn off. You can press the off button 100 times and after about 10 seconds, it automatically flips back on. Never did this before with the old batteries. Worked fine before and now the only way to turn it off (so it doesn't drain batteries when we aren't on the boat) is to turn the "helm power" switch off at the battery switch. That was the solution given to me by the marina which I think is a sign of incompetence frankly.

Weird thing #3, the trim tabs don't appear to be working. Right one seems to work ok but left one shows only going down 1-2 clicks. The buttons have light up little dots that show how low/high the tabs are so no idea if they are actually functioning and those little led lights are screwy or if they aren't working at all.

Weird thing #4, the internal depth finder reads goofy numbers now. When we are in 4' of water, it will say 78.97', 28' of water it will say 2.8 and the alarm will go off, etc. etc.

I had the marina do a diagnostic and they literally didn't look for the problem, they just went to each of the numbered things I listed above, tested them, and then gave me pricing for replacement of entire systems (I.E replacing volt meter, replacing entire trim tab system, replacing entire internal depth finder, etc.).

I think there is something wrong with the battery hookup, grounding wires, the entire electrical wiring setup, etc. but I don't know where to go from here since I am not confident in my marina's service department at all to actually find the smoking gun.

Any help/guidance GREATLY appreciated!!!!
 

dingbat

Supreme Mariner
Joined
Nov 20, 2001
Messages
14,069
I suspect a faulty ground connection.

What is your confidence in electrical troubleshooting?
 

ErieTom99

Recruit
Joined
Jul 26, 2022
Messages
5
I suspect a faulty ground connection.

What is your confidence in electrical troubleshooting?
That was my initial thought as well. Maybe a grounding wire wasnt connected at all or was connected to something wrong. I would say my electrical DIY skills are about 2 out of 10. If I had a picture or something of "this is right" and "this is wrong" I could figure that out but full on start at 0 troubleshooting is not my strong suit with electric
 

dingbat

Supreme Mariner
Joined
Nov 20, 2001
Messages
14,069
That was my initial thought as well. Maybe a grounding wire wasnt connected at all or was connected to something wrong. I would say my electrical DIY skills are about 2 out of 10. If I had a picture or something of "this is right" and "this is wrong" I could figure that out but full on start at 0 troubleshooting is not my strong suit with electric
First thing I would do is to dig around in the area surrounding the batteries for a cable that didn't get reconnected.

IF you put the boat on Battery 2, do the rest of the issues resolve themselves?
 

ErieTom99

Recruit
Joined
Jul 26, 2022
Messages
5
First thing I would do is to dig around in the area surrounding the batteries for a cable that didn't get reconnected.

IF you put the boat on Battery 2, do the rest of the issues resolve themselves?
We are going up this weekend and that is the first thing I am gonna do, put it on battery 2 and check all of the odd things that don't work. Fingers crossed maybe its isolated to battery 1 which will flush out smoking gun. I am gonna take some pictures of the battery bay IF battery 2 doesn't magically solve the weird stuff. I'll update after the weekend.

Have you ever had a battery hooked up incorrectly? Did it "fry" some of the systems? I am worried that's what happened and the marina won't admit it.
 

dingbat

Supreme Mariner
Joined
Nov 20, 2001
Messages
14,069
Have you ever had a battery hooked up incorrectly? Did it "fry" some of the systems? I am worried that's what happened and the marina won't admit it.
Anything is possible but things typically "fry" as in don't work at all.

The GPS thing is suspicious....... almost sounds like the polarity is reversed, has been reversed (hooked up backwards) and or back feeding power through ground from another failed component.

Unless your have the ability to troubleshoot with a volt meter at various points its going to be hard to figure this one out.

What make and model is the GPS?
 
Top