Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse
No announcement yet.

1995 Celebrity 200 Fuel Quantity Issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1995 Celebrity 200 Fuel Quantity Issue

    The fuel quantity indicator reads off scale high, regardless of fuel level in the tank. I have checked wiring for corrosion, cleaned the sender, and verified wiring connections. For grins, I installed a new sending unit-no change. I do notice that when I have the sender out of the tank and connected to the wiring, the indicator moves downward approx. 1/4" when the sender (old or new one) is all the way down (empty tank position). 2 questions: first-is there an adjustment for the indicator to calibrate it to a new sender unit; second-is this an indication of a bad indicator?

  • #2
    Disconnect the sender wire from the gauge and turn on the key. If it stays high, the gauge is bad. If it goes to empty, it could be a wiring problem.

    Is this a new problem?
    BOAT SPECS • FORUM HELP • STARCRAFT FORUM • SHOP iboats
    Please, no PM's (Private Messages) regarding boat/engine problems.
    That is what the forums are for.
    Only forum/moderator issues will be answered in PM's.

    Comment


    • #3
      It is new. The gage goes to empty when I disconnect the sender post wire.

      Comment


      • #4
        Then you have some bad wiring. Did you do anything to the boat prior to the gauge going wacko?
        BOAT SPECS • FORUM HELP • STARCRAFT FORUM • SHOP iboats
        Please, no PM's (Private Messages) regarding boat/engine problems.
        That is what the forums are for.
        Only forum/moderator issues will be answered in PM's.

        Comment


        • #5
          Had power trim pump hoses replaced in the engine compartment and some floor work done. Think I will try accessing the indicator connections, remove the sending wire from the indicator and sender, make up a wire to go from indicator to the sender post and see if that corrects the problem. Sound like a good idea?

          Comment


          • #6
            I ran a new wire direct from the sender stud on the gage to the post on the sending unit, and from the sending unit plate to a known good ground. Same results. Think I need a gage. Any ideas where I might find a replacement? Numbers on the gage housing are 57433 341/94.

            Comment


            • #7
              Does the gauge have a makers name on it. iboats sells gauges - http://www.iboats.com/Marine-Engine-...view_id.217132
              BOAT SPECS • FORUM HELP • STARCRAFT FORUM • SHOP iboats
              Please, no PM's (Private Messages) regarding boat/engine problems.
              That is what the forums are for.
              Only forum/moderator issues will be answered in PM's.

              Comment


              • #8
                Sign up today
                Didn't find a name anywhere, just the numbers. I did take a pic of the front & back. I will take a look.

                Comment

                Working...
                X