Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse
No announcement yet.

95 Kawasaki won't start

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 95 Kawasaki won't start

    We have 2 '95 Kawasaki 750 SS. Took them to the lake last year after we hadn't ran them in a couple years and neither one of them wanted to start. Used some starting fluid and eventually got them both running. One of them ran for about 2 days and then wouldn't start again, the other one ran the whole time. It seemed like the carbs needed cleaning. Was going to take them out a month or so ago and neither one wanted to start. I bought carb rebuild kits for them and replaced all the seals and diaphragms in the carbs. One of them started right up afterwards. The carbs didn't seem overly dirty, but after 25 years I'm sure the seals and diaphragms needed replacing. The other one still won't fire. It will cough every once in a while which it was not doing before, but it doesn't seem like it's getting fuel. There is fuel in the carb. We are getting good spark. One of the spark plugs was wet after trying to start it, the other was dry as can be. Anyone have any ideas for what else to check?

  • #2
    How old is the gas? And what condition is the gas?

    BOAT SPECS | FORUM HELP | STARCRAFT FORUM | SHOP iBoats
    Please, no PM's (Private Messages) regarding boat/engine problems.
    That is what the forums are for.
    Only forum/moderator issues will be answered in PM's.

    Comment


    • #3
      Sign up today
      Gas is about a year old, but had stabilizer in it.

      Comment

      Working...
      X