Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse
No announcement yet.

Quick Question About Wave Runner...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Quick Question About Wave Runner...

    Hello everyone,,,

    Hey guys quick question we took the skie out for the weekend and after loading up and pulling the plugs I notice there was about 4 inches of water inside the ski. Is this normal? We left the ski in the water over night friday and saturday. Its a 2006 Waver Runner VX Sport.... Thanks guys...

  • #2
    4 inches is not normal. I know guys who moor their skis and store their skis in water that don't take on any water.

    Check that all of the tubes for the bilge are connected properly. Specifically, there is a tube from the bilge that hooks to the pump housing which creates a suction effect when the machine is running. Make sure that tube is clear and hooked up to the pump.

    If that hose came undone, water will come in the hull rather than exit the hull.

    Run it in the water to see if there are any leaks in the cooling system when operating. Keep the ski on the trailer and back it into the ramp still hooked up, enough that the intake is underwater. If the ramp is busy, tie it off to the dock out of the way of everyone and perform the same test.

    If you took on water overnight without it running, check all of the seals related to anything going through the hull. This includes the seal around the driveshaft going through the bottom and any steering, trim, or other linkages going to the pump.

    Comment


    • #3
      Hi
      these VX hulls in particular have a well known issue with the intermediate shaft bearing and seal surrounding it. It’s a pig of a job, but loads of info on it online. It’s really well known.

      Comment


      • #4
        Originally posted by GabrialKhan View Post
        Hello everyone,,,

        Hey guys quick question we took the skie out for the weekend and after loading up and pulling the plugs I notice there was about 4 inches of water inside the ski. Is this normal? We left the ski in the water over night friday and saturday. Its a 2006 Waver Runner VX Sport.... Thanks guys...

        Thank you my issue has been solved,..
        Last edited by GA_Boater; August 20th, 2019, 05:17 PM. Reason: Removed stupid reverse phone look up link.

        Comment


        • #5
          What was the issue? How did you fix it? Future readers might find it helpful, kind of rude to not update everyone fully...

          Comment


          • #6
            Sign up today
            Cleaning out the Mumbai spammers.
            BOAT SPECS | FORUM HELP | STARCRAFT FORUM | SHOP iBoats
            Please, no PM's (Private Messages) regarding boat/engine problems.
            That is what the forums are for.
            Only forum/moderator issues will be answered in PM's.

            Comment

            Working...
            X