Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse

Private Messages

We are aware of a current issue where your messages screen does not properly load and we are working on a fix.

In the interim, you can access you messages by navigating to this link: https://forums.iboats.com/privatemessage/notification

Apologies for the inconvenience.
See more
See less

2001 sea Doo GTX RFI

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2001 sea Doo GTX RFI

    I recently purchased this machine, it had a seized motor. I rebuilt the motor and now it runs great but my problem is that when I put it back in I broke the nipple on the rave exhaust solenoid . The line from the crankcase is hooked up but the one that broke was the one that goes to the 2 rave valves . I have not put it in the water yet just running it on the garden hose will it be alright to do this prior to replacing it?

  • #2
    The Rave valves open as rpm increases and close as it goes down. I don't know of a manufacture that adds things to a motor that it doesn't need other then smog stuff. If it was mine I wouldn't run it
    94 Formula 27PC Custom 509MPI MEFI3 , B3 XR
    95 Rinker 232 w/ 7.4L Carb 0F425011 B1 0F486471
    07 Seadoo GTX
    Merc Adults Only VP Adults Only
    G-Dad always said "First Liar doesn't stand a chance"

    Comment


    • #3
      I don't want to put it in the water and ride it I just want to run it while on the garden hose to make sure everything is good and there are no leaks in the system. So if I keep it at just an idle low-rpm don't rev it that should be fine cuz those are valves with them stay closed .I have seen those valves on eBay and on the internet for like $30 so I do plan on changing it

      Comment


      • #4
        OK, then I to would have no problem running it
        94 Formula 27PC Custom 509MPI MEFI3 , B3 XR
        95 Rinker 232 w/ 7.4L Carb 0F425011 B1 0F486471
        07 Seadoo GTX
        Merc Adults Only VP Adults Only
        G-Dad always said "First Liar doesn't stand a chance"

        Comment


        • #5
          Yeah. Just be careful. Not totally familiar with the RFI but had the DI with rave valves. It had a driven compressor to operate or assist their operation. They can run without them opening but they foul up real bad and stick if not operating.

          Comment


          • #6
            That's Seadoo's version of a power valve. As stated, it won't hurt anything, but all you'll have is decent low end, and no top end what so ever.
            They basically change the size and shape of the exhaust port as they open and close.

            Comment


            • #7
              Thanks everyone, I now have another issue I am struggling with .the ski was running great I shut her down and the next night after work I came back to her to run again and it wouldn't start I checked the spark that was good ( just put new plugs in also) no issues with the throttle body that I could see so I pulled the injectors to see if there was fuel and there was not. I checked all the connections they where good. I then pulled the fuel.oump out and sure enough the filters where nasty .I tried to clean them and just run it again but nothing the fuel pump wouldn't even turn on so I ordered a new pump and filters thinking it was bad .I got them today and installed them a d still the pump won't run .I hear the mpem click, I see 12volts on the positive line to the pump for a split second then it drops to about 5 volts .it never builds any pressure or runs .I checked all connections on the mpem they are all good I checked the fuse and it has a constant 12 Volts each side. I a .confused any help.would be greatly appreciated.

              Comment


              • #8
                From looking at the manual it shows a Black/Pink and Purple/Pink wires feeding the pump. Guessing from the colors I would say Purple/Pink is hot and the other is grounded by the computer to turn it on

                Click image for larger version

Name:	rfi.jpg
Views:	1
Size:	32.7 KB
ID:	10726187
                94 Formula 27PC Custom 509MPI MEFI3 , B3 XR
                95 Rinker 232 w/ 7.4L Carb 0F425011 B1 0F486471
                07 Seadoo GTX
                Merc Adults Only VP Adults Only
                G-Dad always said "First Liar doesn't stand a chance"

                Comment


                • #9
                  Yeah, I have been through all the wiring and taced them back to the mpem and they all check out . I am wondering if I connect the black pink directly to ground if I can trick the pump to turn on.

                  Comment


                  • #10
                    I wouldn't do that. To test the pump, remove the connector and use a battery with a fuse direct. I'm thinking you may have a pump that has locked up
                    94 Formula 27PC Custom 509MPI MEFI3 , B3 XR
                    95 Rinker 232 w/ 7.4L Carb 0F425011 B1 0F486471
                    07 Seadoo GTX
                    Merc Adults Only VP Adults Only
                    G-Dad always said "First Liar doesn't stand a chance"

                    Comment


                    • #11
                      I just purchased the pump .would the float have anything to do with it? I see on some sea doo's there fuel pump have different resistance levels as the fuel changes levels, if that didn't work would that stop the op from running?

                      Comment


                      • #12
                        The fuel gauge or sender should have no effect on the pump. In a previous post you mentioned
                        I see 12volts on the positive line to the pump for a split second then it drops to about 5 volts
                        Going from 12 to 5V would have me thinking the pump is drawing to much current. Even if the line a filter was clogged up, the pump should still run if its not clogged up
                        94 Formula 27PC Custom 509MPI MEFI3 , B3 XR
                        95 Rinker 232 w/ 7.4L Carb 0F425011 B1 0F486471
                        07 Seadoo GTX
                        Merc Adults Only VP Adults Only
                        G-Dad always said "First Liar doesn't stand a chance"

                        Comment


                        • #13
                          I just received a brand new pump and filters and it is still doing the same thing. I am confused this should be straight forward. Voltage from the MPEM to the pump through the purple pink wire and the black pink being the ground. Looks like all the MPEM does is turn it on and off. I have checked the wires all the way from the connector to the MPEM and they are good, unplugged #2 connector from the MPEM and the connections are not corroded, new pump,new inner filter, new outer filter. I am baffled.

                          Comment


                          • #14
                            Your at a place now where I don't have the info or tools to go further. I would think you need a dealer to scan the MPEM.

                            You might be able to hot wire the pump, but thinking there may be other things going on. The GTX RFI is a power hungry machine, so even a weak bat can cause issues.
                            94 Formula 27PC Custom 509MPI MEFI3 , B3 XR
                            95 Rinker 232 w/ 7.4L Carb 0F425011 B1 0F486471
                            07 Seadoo GTX
                            Merc Adults Only VP Adults Only
                            G-Dad always said "First Liar doesn't stand a chance"

                            Comment


                            • #15
                              Sign up today
                              So I just went to the garage and removed the pump again I unplugged the connector that is on the inside of the housing and then used jumpers ( exteded paper clips) to go between that connection and the connector that comes from the MPEM .I then plugged the key in and the pump ran and then shut off , so it looks like the intermediate connection is bad .has anyone ever seen this happen before?

                              Comment

                              Working...
                              X