Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse
No announcement yet.

2004 Yamaha 150 hpdi Alarm and tach issue

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2004 Yamaha 150 hpdi Alarm and tach issue

    Had my 150 running with muffs on and the alarm started to buzz after 2 minutes running. Noticed low amount of water coming out so I cleaned the port and plenty of water comes out now. Alarm is still buzzing though. Both oil tanks are full. Any thoughts?

    Maybe this has something to do with it or maybe not: Before cranking I installed a used analog non Yamaha tack, hooked the 3 wires and cranked it. The tach wont go past 100 and jumps around between 1-100 no matter where the throttle is positioned. Bad tack? bad connection?

    do the two issues have something to do with each other?

    Last week ran the motor on land and no problems at all, no tack was installed, no buzzer going off.

  • #2
    Re: 2004 Yamaha 150 hpdi Alarm and tach issue

    No relation and it's probably the overheat alarm. As for the tach, do you have the pole setting correct?

    Comment


    • #3
      Re: 2004 Yamaha 150 hpdi Alarm and tach issue

      First time I've ever had a tach. Not sure what you are talking about. Ive got the three wires in the correct places.

      Comment


      • #4
        Re: 2004 Yamaha 150 hpdi Alarm and tach issue

        is this a new tach?
        Should have come with instructions to set it properly for your motor.
        Is the buzzer sounding as soon as you turn on key or after running motor for awhile?
        You could unplug the wires to tach to see if buzzer quits, but should not have anything to do with each other unless you wired things up all wrong

        Comment


        • #5
          Re: 2004 Yamaha 150 hpdi Alarm and tach issue

          On the rear of the tach is a switch that changes the pole settings for the different engines. If yours doesn't have it then you have the wrong tach.

          Comment


          • #6
            Re: 2004 Yamaha 150 hpdi Alarm and tach issue

            I bought the tach used, however it was used on an identical motor to what i have. There is adjustment for the poles, i just left it the way it was because the seller said it was an identical motor. Any idea what setting the poles should be on? The motor will run for about ten minutes and the alarm will begin to sound. When you turn the key off and turn it back on to ignition the alarm rings but if you let it sit for ten minutes it won't ring for another ten. This just started happening yesterday, never had the problem before.

            Comment


            • #7
              Re: 2004 Yamaha 150 hpdi Alarm and tach issue

              If alarm come on when only at low RPMs then it could be a stuck open PRV dumping too much water and not letting the motor fill all of the way up with water. Which will not give any cooling to the top cylinders

              What wires did you hook up to the tach?
              Was a harness used?
              Just not enough info from OP to even guess at the real problems
              Last edited by 99yam40; January 13th, 2014, 11:08 AM.

              Comment


              • #8
                Re: 2004 Yamaha 150 hpdi Alarm and tach issue

                The engine is overheating and the reason for the alarm. As for the tach, being its used there's a good posibility its a faulty unit.

                Comment


                • #9
                  Re: 2004 Yamaha 150 hpdi Alarm and tach issue

                  Wires hooked up were green, black and yellow. Hard wired off yamaha harness. Going by this chart Wiring Color Codes for YAMAHA Outboard Motors.

                  How is a stuck open prv fixed? Ive got no clue what that is.

                  Comment


                  • #10
                    Re: 2004 Yamaha 150 hpdi Alarm and tach issue

                    Originally posted by Capt Ken View Post
                    The engine is overheating and the reason for the alarm. As for the tach, being its used there's a good posibility its a faulty unit.
                    Capt Ken
                    do the Hpdi motors take the tach signal from the lighting coil or the ECU?
                    This may be his problem if he it hooking up to the green wire from the controls

                    Comment


                    • #11
                      Re: 2004 Yamaha 150 hpdi Alarm and tach issue

                      Originally posted by Craigslistmaniac View Post
                      Wires hooked up were green, black and yellow. Hard wired off yamaha harness. Going by this chart Wiring Color Codes for YAMAHA Outboard Motors.

                      How is a stuck open prv fixed? Ive got no clue what that is.
                      You take it out and clean or install a new one

                      Comment


                      • #12
                        Re: 2004 Yamaha 150 hpdi Alarm and tach issue

                        I'm actually thinking it still comes off the voltage regulator
                        Last edited by Capt Ken; January 13th, 2014, 07:50 PM.

                        Comment


                        • #13
                          Re: 2004 Yamaha 150 hpdi Alarm and tach issue

                          Originally posted by 99yam40 View Post
                          You take it out and clean or install a new one
                          Where is it located? Ive never messed with one before. Diagram, picture, or video would help.

                          Comment


                          • #14
                            Re: 2004 Yamaha 150 hpdi Alarm and tach issue

                            Originally posted by Capt Ken View Post
                            I'm actually thinking it still comes off the voltage regulator
                            So witch wire should I be using instead or stick with what I've got? Will I mess things up if I switch around the poles on the switch thing?

                            Comment


                            • #15
                              Sign up today
                              Re: 2004 Yamaha 150 hpdi Alarm and tach issue

                              Click image for larger version

Name:	tach.png
Views:	1
Size:	44.4 KB
ID:	7100040

                              what the back of tach looks like

                              Comment

                              Working...
                              X