Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse
No announcement yet.

Yamaha 175 steering unresponsive but the cable is fine?!?! Is there a safety lock?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Yamaha 175 steering unresponsive but the cable is fine?!?! Is there a safety lock?

    So I went out on the boat 5 weeks ago and had no problems. I went back last week and started the motor, no problems and then went to steer and nothing. Couldn't budge the engine left or right. I disconnected the steering cable and once out the rod is fine and the wheel steers left to right no problem. There is tons of lithium grease all over the place to keep it moving fluidly. Am I missing something? Is there some kind of steering safety lock that got engaged and prohibits me from moving the wheel? Any help would be great. Thanks.
    Attached Files
    lord, protect me from your followers.

  • #2
    Re: Yamaha 175 steering unresponsive but the cable is fine?!?! Is there a safety lock

    With the cable disconnected and extended as in your first picture, can you grab the motor and turn it back and forth? If not the tube attached to the end of the steering cable is froze up inside the pivot tube.
    Don S.


    Please, no PM's (Private Messages) regarding boat/engine problems.
    That is what the forums are for.
    Only forum/moderator issues will be answered in PM's.

    Comment


    • #3
      Re: Yamaha 175 steering unresponsive but the cable is fine?!?! Is there a safety lock

      Nope - can't rotate it by hand when the steering pin is out. How do I free up the pivot tube? Thanks for you help!
      lord, protect me from your followers.

      Comment


      • #4
        Re: Yamaha 175 steering unresponsive but the cable is fine?!?! Is there a safety lock

        Originally posted by mountforever View Post
        Nope - can't rotate it by hand when the steering pin is out. How do I free up the pivot tube? Thanks for you help!
        What "steering pin" are you referring to. I asked if you could turn the motor itself when the steering cable was disconnected and the cable extended as in your first picture.
        Don S.


        Please, no PM's (Private Messages) regarding boat/engine problems.
        That is what the forums are for.
        Only forum/moderator issues will be answered in PM's.

        Comment


        • #5
          Re: Yamaha 175 steering unresponsive but the cable is fine?!?! Is there a safety lock

          Nope - can't rotate by hand. the "steering pin" is the straight pin that is connected to the steering cable. it screws into that threaded piece that puts it in the pivot tube. The steering cable and pin are disconnected from the threaded piece for the picture's sake.
          lord, protect me from your followers.

          Comment


          • #6
            Re: Yamaha 175 steering unresponsive but the cable is fine?!?! Is there a safety lock

            In the picture below, I painted the steering cable parts green, and the link that connects the motor to the cable blue.
            Disconnect the link arm (Blue) from the steering cable end (green) and with the cable nut loose, drive the cable out of the pivot tube through the motor. DO NOT use a steel punch. A wood dowel rod should work fine.



            What happens is corrosion builds up between the stainless steel cable end and the aluminum pivot tube. and causes your steering to bind.
            Just clean all the corrosion out of the tube, and off the cable end. Put some anti corrosion grease on the cable and in the tube and put it back together and it should move easily again.










            .
            Attached Files
            Don S.


            Please, no PM's (Private Messages) regarding boat/engine problems.
            That is what the forums are for.
            Only forum/moderator issues will be answered in PM's.

            Comment


            • #7
              Re: Yamaha 175 steering unresponsive but the cable is fine?!?! Is there a safety lock

              Great! Thank you so much for your help Don. I'll probably get to it in the next few days and I'll let you know how it went. You are the man.
              lord, protect me from your followers.

              Comment


              • #8
                Re: Yamaha 175 steering unresponsive but the cable is fine?!?! Is there a safety lock

                You are lucky that you have plenty of room to get the cable out without removing the engine.

                Comment


                • #9
                  Re: Yamaha 175 steering unresponsive but the cable is fine?!?! Is there a safety lock

                  So as it turned out I disconnect the swing arm. The motor moved left and right fine. The problem was actually on the right hand side by the swing arm. I took off the threaded cap and put some vise grips on the steering pin. It was basically stuck in there. I just flooded it with wd-40 and tried to move it and rotate it. Bit by bit it got looser until I was able to pull it in and out. But pushing it through on the left wans't an option as the pin doesn't come apart from the cable. I lubed it back up with grease and now it steers with one finger. Thanks for everyone's input!
                  lord, protect me from your followers.

                  Comment


                  • #10
                    Re: Yamaha 175 steering unresponsive but the cable is fine?!?! Is there a safety lock

                    It will last only a short while before seizing again since you did not clean the corrosion from inside the tube. The pin ( shaft) as you call it, is the cable. It will all extract out the starboard side of the tube. The first time you let it set for a few weeks, it will freeze up again and next time you may not be so lucky.

                    Comment


                    • #11
                      Re: Yamaha 175 steering unresponsive but the cable is fine?!?! Is there a safety lock

                      yes, i did clean out the inside and clean the pin. thanks though.
                      lord, protect me from your followers.

                      Comment


                      • #12
                        Sign up today
                        Re: Yamaha 175 steering unresponsive but the cable is fine?!?! Is there a safety lock

                        Sounded like you could not remove cable from tube from what you wrote.

                        What did you use to clean out the corrosion from tube?

                        Comment

                        Working...
                        X