Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse
No announcement yet.

suzuki dt140 (1988) runs but then dies. no spark after engine runs a few minutes

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • suzuki dt140 (1988) runs but then dies. no spark after engine runs a few minutes

    As stated above my dt140 runs for a few minutes and then slowly dies and wont restart. ive had to swim it to shore last 2 times taking it out. Im wondering if the sensors, water flow, oil or temp will kill the engine as a fail safe. After I get the boat home and let it sit for a few hours, the engine will start up again. I dont think it is a fuel issue. This condition has gotten worse, meaning, it starts cutting out and dying sooner after starting. thanks in advance for any and all help.

  • 99yam40
    replied
    Re: suzuki dt140 (1988) runs but then dies. no spark after engine runs a few minutes

    So you did your carbs and water pump last year, and you needed to do the carbs again this year.
    why do you rule out the water pump like you tried to do the carbs?

    Just saying never rule out anything just because you do not think that it is the problem. always test/inspect anything that can cause problems

    Leave a comment:


  • James R
    replied
    Re: suzuki dt140 (1988) runs but then dies. no spark after engine runs a few minutes

    Just one final word. It is not unusual to have dirt in the tank, congealed fuel will do it. Failure to use Stabil in the fuel and a big Water trap filter in the fuel line may result in a similar failure. My DT140 has these things since I had similar problems and I have not had a problem for a few years. The motor will thank you for your consideration. Great motor.

    Leave a comment:


  • warrior1
    replied
    Re: suzuki dt140 (1988) runs but then dies. no spark after engine runs a few minutes

    well, thanks for all the help. as it stands, i am a officially a dunce. I misdiagnosed the engine problem. I do have spark to all cylinders. I realized i was looking at my spark tester in the direct sunlight, couldnt see the spark. So problem solved there. However, the carbs where full of crud. I just did them last year so I didnt think it was them. It was. I pulled them and disassembled them and cleaned them thoroughly. Engine now runs wonderfully. But i still have the engine going into limp mode at 3000rpm. So i will need to diagnose that issue.
    I just did the water pump impeller last year also so I dont think it is that. I will now focus on the flow meter switch or the oil switch.
    Once again, thanks for all the suggestions and help.

    Leave a comment:


  • James R
    replied
    Re: suzuki dt140 (1988) runs but then dies. no spark after engine runs a few minutes

    Disconnect the controls connector at the engine. Disconnect the yellow wire at the starter solenoid. If you have inline spark checkers use them or pull the plugs and reconnect to the plug wires. Use heavy copper wire to ground all the plugs. Wire a toggle switch and connect one end to the + battery connection at the solenoid and the other end to the yellow wire on the solenoid. You can now turn the motor over and check for sparks. If you use inline checkers with the plugs still connected the motor may fire so have the water supply hooked up and running. This procedure is simple and will eliminate the emergency stop and the ignition switch as the cause. Of course if you are using this in salt water the first thing is clean connections.
    The Suzuki systems are very reliable but CDI's can fail.

    Leave a comment:


  • warrior1
    replied
    Re: suzuki dt140 (1988) runs but then dies. no spark after engine runs a few minutes

    thanks, ill get one tomorrow.

    Leave a comment:


  • 99yam40
    replied
    Re: suzuki dt140 (1988) runs but then dies. no spark after engine runs a few minutes

    pick up a DVA adapter to use with your DVM to be able to compare to specs in manual. Bad input give no good output

    Kill switch and key switch is all I know about

    Leave a comment:


  • warrior1
    replied
    Re: suzuki dt140 (1988) runs but then dies. no spark after engine runs a few minutes

    99 yam - how would one go about testing the inputs on the cdi with a DVM? i read the procedure in the manual but it states to use a different piece of equipment. is it possible to use a dvm and check the voltage on DC input? i am now trying to start the motor on muffs and am getting no spark to any of the 4 coils. should i immediately suspect the CDI box, or is there any other kind of fail safe that would be killing the spark. (besides the safety override on the control box)

    Leave a comment:


  • warrior1
    replied
    Re: suzuki dt140 (1988) runs but then dies. no spark after engine runs a few minutes

    thanks, i ll try that next week.

    Leave a comment:


  • 99yam40
    replied
    Re: suzuki dt140 (1988) runs but then dies. no spark after engine runs a few minutes

    need to test inputs and out puts of CDI while problem exists to see what is failing

    Leave a comment:

Working...
X