Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse
No announcement yet.

Help with issue! Yamaha C50TLR

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help with issue! Yamaha C50TLR

    Any info help for a Yamaha C50TLR 2 stroke with the prop
    disengages
    when running more than idling. The engine runs great.

  • #2
    Maybe gear selector is out of adjustment....drop lower unit and move shifter shaft until you find neutral(by rotating the prop by hand)...then put your motor control lever in neutral position, re-install lower unit....hopefully this will solve your problem

    Comment


    • #3
      Thank for reply.I will check it.

      Comment


      • #4
        Are you saying that the motor runs fine at idle but when you put it in gear the prop does not spin? If so you either spun the prop in which you have to take it to a shop or if there's a shear pin it broke. Easy fix. Pull the prop and look for a broken pin. Did you hit anything in the water that you know of, or did any work on the lower end?

        Comment


        • #5
          No the prop runs OK at slow rpms. Just when I give it gas the prop stops & motor continues running fast'

          Comment


          • #6
            still sounds like the prop spun or shear pin broke. have you pulled the prop to see if it has a shear pin? with the motor in gear and not running grab the prop and see if you can spin it both clockwise and counter clockwise?

            Comment


            • #7
              Sign up today
              Thanks. I will try that first.

              Comment

              Working...
              X