Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse
No announcement yet.

No start on one engine

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • jrisebo
    started a topic No start on one engine

    No start on one engine

    Had an no start condition on one engine. It was fine, then it wasnt. we were just drifting, and then would start up and move. after about 3 times, starboard engine would not start. Checked all things electrical, and then it was getting hard to shift in and out of neutral to the point it was stuck in reverse. Hobbled back to the dock on port engine, then played around with starboard side, and it would now shift into nuetral, forward, etc. But still no start. Is the neutral position switch inside the control mechanism? Any way to change that, check it, etc?

  • jrisebo
    replied
    They are VP Duo-prop. Turns out it was the starter relay switch went bad.

    The shifting is working now.

    Not sure where I can find the shift control if I wanted one, seems the VP parts store does not have my style listed.



    Leave a comment:


  • AllDodge
    replied
    If it was a Bravo drive I would say its the neutral safety switch, and when its in gear and motor is not running, it takes some doing to get back in neutral. Most cases the neutral safety is in the throttle control, unless its a newer model then on the shift plate or transmission for inboards

    I'm assuming its VP because its in this section, but no mention of motor or drive?

    Leave a comment:

Working...
X