Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse
No announcement yet.

1988/83 Mercury 115 6 Cyl Technical questions

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1988/83 Mercury 115 6 Cyl Technical questions

    Good Day, my brother (mainly) and I have restored a 1966 Boat Locker "Malibu" The boat originally had a 1965 Mercury 1000 6 Cyl. Unfortunately we could not save the powerhead.

    We opted to get an 80s model 6cyl with PTT, and the newer ignition system, in order to make it a bit more practical to use. After a year we managed to build a inline 6 with the 88 lower unit, PTT and gearbox, and an 83 Powerhead.

    I have experience with OMC and the Japanese brands, but 0 on Mercury and even less on inline 6s

    here is a pic, 66 decals on, contemplating if we must do the 66 engine covers and crome beadings..

    Click image for larger version

Name:	rear.jpg
Views:	1
Size:	128.1 KB
ID:	10695340Click image for larger version

Name:	side m.jpg
Views:	1
Size:	97.6 KB
ID:	10695341Click image for larger version

Name:	tank.jpg
Views:	1
Size:	103.8 KB
ID:	10695342



    Issue 1:

    Cooling system
    Engine running water is coming out of pee-hole AND a tube on the water jacket between the spark plugs

    Click image for larger version

Name:	Pee hole.jpeg
Views:	1
Size:	71.4 KB
ID:	10695343

    I put a hose on it routed to the engine tray to prevent water from being sprayed over plugs

    Issue 2:

    Motor starts, idles, a bit rough, and runs great for a few minutes, then it goes into a limp.

    Action taken
    Swopped out coil packs
    New Sparkplugs
    Sprayed a whole can of Quicksilver Power Tune to dicarbon
    Cleaned Carbs

    Any ideas will be appreciated,

    here are some pics of the maiden voyage, after a 4 year restoration project
    Click image for larger version

Name:	launch.jpg
Views:	1
Size:	111.4 KB
ID:	10695344Click image for larger version

Name:	water.jpg
Views:	1
Size:	75.9 KB
ID:	10695345Click image for larger version

Name:	side wide.jpg
Views:	1
Size:	139.2 KB
ID:	10695346




  • #2
    Issue 1---The tube on the water jacket would be for a water pressure gauge.------You can just put a pipe plug in there like when it left the factory.---Issue 2 -----Other than just guessing and replacing parts what other trouble shooting was done ?

    Comment


    • #3
      Originally posted by racerone View Post
      Issue 1---The tube on the water jacket would be for a water pressure gauge.------You can just put a pipe plug in there like when it left the factory.---Issue 2 -----Other than just guessing and replacing parts what other trouble shooting was done ?
      Checked for Spark on all cylinders, that's it...

      Comment


      • #4
        Compression test done ?----Replaced fuel pump diaphragm ?--------Tried adjusting the low speed mixture screws.

        Comment


        • #5
          Sign up today
          On some of the older inlines that fitting was where the tel-tale was connected. The fitting looks like the right size for that, the fitting for the water pressure gauge was bit different

          Comment

          Working...
          X