Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse
No announcement yet.

1979 Mercruiser 140

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1979 Mercruiser 140

    I am going to rebuild my 1979 Mercruiser 140, the oil is milky colored and there was rust flakes inside the hoses and where the carb mounts on. Any suggestions?

  • #2
    Re: 1979 Mercruiser 140

    Hello Dman and welcome aboard.

    First thing is to find out WHY your oil is milky. If it's a cracked block, rebuilding won't fix it, it'll need a new block...
    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    The world takes on a whole new perspective when viewed from 100’ below.
    1972 Bertram ‘Bahia Mar’ 20
    2006 Mercruiser 4.3MPI (0W617679) w/Alpha One Gen II (0W829301)
    (Original - 1972 '165' In-line 6. Previous - 1994 4.3LX)


    Comment


    • #3
      Re: 1979 Mercruiser 140

      Originally posted by Dman1252 View Post
      I am going to rebuild my 1979 Mercruiser 140, the oil is milky colored and there was rust flakes inside the hoses and where the carb mounts on. Any suggestions?
      Ayuh,.... Welcome Aboard,.... Lets do some Testin', 'n Diagnosin' to see what's Ok, 'n what needs Fixin',...

      The milky oil is a red flag for a frozen busted block, so lets start with a coolin' jacket pressure test,...

      Pictures sure would Help,...
      Postin' instructions are pinned at the top of the Tech, Non-boatin' forum,...
      Last edited by Bondo; March 3rd, 2014, 03:52 PM. Reason: I guess my single digit is Slippin',....

      Comment


      • #4
        Re: 1979 Mercruiser 140

        Thanks!! So I noticed that one of the freeze plugs was popped out so I'm assuming the owner before me let water get into the engine, he took the carb off and had it in a box and that's how I got it all. I bought the boat which is a 1979 Chaparral 167 with the trailer and engine for $300. I wanted a spring project so I said what the heck... The floor was all rotted and the foam was moldy and saturated as well. I will post some pics as soon as I can take some good ones.

        Comment


        • #5
          Re: 1979 Mercruiser 140

          I think you indeed have a project! It sure sounds like the motor is beyond repair. Check for water in your drive. And if the floor + stringers (probably transom) are rotted, it'll be a long time before the boat is sea worthy. Spend some time searching the forums like this one and especially the Restore forum to size up what you're looking at.

          Comment


          • #6
            Sign up today
            Re: 1979 Mercruiser 140

            Hmmm well that's no fun! Haha thanks for the info!

            Comment

            Working...
            X