Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse
No announcement yet.

engine not priming with muffs on, need some info plz

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • engine not priming with muffs on, need some info plz

    Hi guys,i just bought a 2005 regal 2250 with a 5.7 mag mpi. When i was with the po we cranked up the engine with muffs on but no water was coming out, this was the engines first crank since being winterized. We took one hose off filled it up and after it was fine. Next day i have the boat at my place and after changing the oil i fire it up again and 10 15 secs still no water. Muffs were on fine. Should i wait longer for the water to start running out. Anyways i later that day put the boat in the water and was concerned that it might not be sucking up water but since its in water i cant see it. temp rose to 175,dropped and later on it that day it never went higher than 135 or so.
    This normal or whats going on here?
    Tks for the help

  • #2
    Re: engine not priming with muffs on, need some info plz

    What drive? Does it have an engine mounted raw water pump?
    87 Formula F223LS, 2016 383 Stroker, 2019 Davis Unified(HEI) Ignition, Quickfuel Marine 750
    Lake Winnipesaukee, NH

    Comment


    • #3
      Re: engine not priming with muffs on, need some info plz

      Ya sry forgot to mention,bravo1 drive

      Comment


      • #4
        Re: engine not priming with muffs on, need some info plz

        Bet you are due for a new impeller. How old is the one in there?
        Don S.


        Please, no PM's (Private Messages) regarding boat/engine problems.
        That is what the forums are for.
        Only forum/moderator issues will be answered in PM's.

        Comment


        • #5
          Re: engine not priming with muffs on, need some info plz

          Po said it was changed last year.ill take it in to have it changed and looked at

          Comment


          • #6
            Re: engine not priming with muffs on, need some info plz

            Originally posted by rick911 View Post
            Po said it was changed last year.ill take it in to have it changed and looked at
            Just a guess here, but I would bet this is what the previous owner said before you bought the boat, and you didn't take a test run before you bought it.

            Am I close?
            Don S.


            Please, no PM's (Private Messages) regarding boat/engine problems.
            That is what the forums are for.
            Only forum/moderator issues will be answered in PM's.

            Comment


            • #7
              Sign up today
              Re: engine not priming with muffs on, need some info plz

              We took the boat for test of course, temp never got high but then again we didnt test it for hours,20-25 mins.

              Comment

              Working...
              X