Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse

Help Tip: If you have a question that has not been answered to your satisfaction in the archives, it is always best to start a new thread of your own. By starting your own thread, you will receive the maximum number of views by forum members.

Please note this topic has been inactive for 90 days. For the best results, please start a new topic.

Thank you all in advance for doing your part in helping iboats run a smooth ship.

Additional forum rules linked below.
http://forums.iboats.com/forum-rules-guidelines-405/
See more
See less

Alpha one Gen II Gimbal Bearing grease fitting missing?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Alpha one Gen II Gimbal Bearing grease fitting missing?

    Hi all, I have a 2000 Mercruiser 5.7L EFI with an Alpha one Gen II outdrive and in going through routine maintenance, I noticed I don't have a grease fitting at the gimbal housing. I have what looks like a torx bit screw. Does this mean that I have a perma lube bearing in place? I've attached a picture. Thanks in advance!

    --Joe

    Click image for larger version

Name:	2013-05-05 14.46.29.jpg
Views:	1
Size:	142.9 KB
ID:	7183316

  • #2
    Re: Alpha one Gen II Gimbal Bearing grease fitting missing?

    That plug is used when a permalube bearing is installed.
    Did you have the gimbal bearing or drive work done to your boat?
    Don S.


    Please, no PM's (Private Messages) regarding boat/engine problems.
    That is what the forums are for.
    Only forum/moderator issues will be answered in PM's.

    Comment


    • #3
      Re: Alpha one Gen II Gimbal Bearing grease fitting missing?

      In looking at the paperwork from my bellows replacement last year, the gimbal bearing was replaced.
      Thanks for the speedy reply Don!
      Last edited by joeybobo; May 6th, 2013, 02:10 PM. Reason: added a thank you

      Comment


      • #4
        Sign up today
        Re: Alpha one Gen II Gimbal Bearing grease fitting missing?

        Originally posted by joeybobo View Post
        In looking at the paperwork from my bellows replacement last year, the gimbal bearing was replaced.
        Thanks for the speedy reply Don!
        You should ask them, they would know for sure since they did the job. All I can tell you for sure is the plug is there instead of the zirk.
        Don S.


        Please, no PM's (Private Messages) regarding boat/engine problems.
        That is what the forums are for.
        Only forum/moderator issues will be answered in PM's.

        Comment

        Working...
        X