Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse

Help Tip: If you have a question that has not been answered to your satisfaction in the archives, it is always best to start a new thread of your own. By starting your own thread, you will receive the maximum number of views by forum members.

Please note this topic has been inactive for 90 days. For the best results, please start a new topic.

Thank you all in advance for doing your part in helping iboats run a smooth ship.

Additional forum rules linked below.
http://forums.iboats.com/forum-rules-guidelines-405/
See more
See less

Outdrive WONT trim up with "trim up" switch but will with "trailer switch"

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Outdrive WONT trim up with "trim up" switch but will with "trailer switch"

    Outdrive WONT trim up with "trim up" switch but will with "trailer switch"... Where do I start..?
    89 Sea Ray Seville 4.3 merc

  • #2
    Re: Outdrive WONT trim up with "trim up" switch but will with "trailer switch"

    its a 89 sea ray 4.3 merc alpha
    89 Sea Ray Seville 4.3 merc

    Comment


    • #3
      Re: Outdrive WONT trim up with "trim up" switch but will with "trailer switch"

      trim limit switch, port side of gimbal ring
      Sometimes when people try to save a penny, they end up spending a dollar

      It is best to fully understand how to properly operate, inspect, troubleshoot and repair your equipment

      Comment


      • #4
        Re: Outdrive WONT trim up with "trim up" switch but will with "trailer switch"

        Here is a troubleshooting chart.
        Attached Files
        Don S.


        Please, no PM's (Private Messages) regarding boat/engine problems.
        That is what the forums are for.
        Only forum/moderator issues will be answered in PM's.

        Comment


        • #5
          Sign up today
          Re: Outdrive WONT trim up with "trim up" switch but will with "trailer switch"

          Thanks I will work on it tomorrow... I think I know what the problem is now. I noticed a red wire with an inline fuse but fuse was missing. Im pretty sure that is where I find the problem..
          89 Sea Ray Seville 4.3 merc

          Comment

          Working...
          X