Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse
No announcement yet.

Issue after coupler install

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issue after coupler install

    Hello, I’ve got an 88 Marlin w 4.3 Alpha 1....
    Had a guy replace my coupler recently which went well aside from the following issue..
    I lost power to my bilge pump, exhaust fan, trim gauge, gas gauge, and stern and bow lights...
    The mechanic is an hour plus away and he tried to describe what he may have failed to reattach after the engine pull/reinstall..
    He thought it was maybe a smaller wire from the battery to those accessories, after a while of searching I can’t find anything that looks relevant...
    Any thoughts on this would be appreciated, thanks

  • #2
    Look for a Ground wire, even negative battery cable to the engine block
    94 Formula 27PC Custom 509MPI MEFI3 , B3 XR
    95 Rinker 232 w/ 7.4L Carb 0F425011 B1 0F486471
    07 Seadoo GTX
    Merc Adults Only VP Adults Only
    G-Dad always said "First Liar doesn't stand a chance"

    Comment


    • #3
      The negative battery to the block is secure, I have good power to start the boat, trim works as it should...
      I thought it would be obvious but no such luck

      Comment


      • #4
        Boat will start, thats good to know

        Look over by the starter connections for a wire not connected

        Your accessories are not working. The trim gauge has a connection which would be near the trim pump, there are 2 wires with bullet connectors. One goes to ground and other connects to Brown/White which goes to gauge

        See how many wires are on the 90 fuse on the starter

        Click image for larger version

Name:	90 amp fuse.jpg
Views:	15
Size:	4.2 KB
ID:	10869135Click image for larger version

Name:	Starter connect.jpg
Views:	10
Size:	39.8 KB
ID:	10869136
        94 Formula 27PC Custom 509MPI MEFI3 , B3 XR
        95 Rinker 232 w/ 7.4L Carb 0F425011 B1 0F486471
        07 Seadoo GTX
        Merc Adults Only VP Adults Only
        G-Dad always said "First Liar doesn't stand a chance"

        Comment


        • #5
          Ok I’ll look at the starter, one other weird thing is that when I flip either the bilge pump or exhaust fan switches the goggles are illuminated (both toggles) but no power to either device

          Comment


          • #6
            A ground is disconnected, when fan is turned on its back feeding to get a ground.
            94 Formula 27PC Custom 509MPI MEFI3 , B3 XR
            95 Rinker 232 w/ 7.4L Carb 0F425011 B1 0F486471
            07 Seadoo GTX
            Merc Adults Only VP Adults Only
            G-Dad always said "First Liar doesn't stand a chance"

            Comment


            • #7
              Ok any idea which? Or where I should start? Or which ground would typically be removed for an engine pull?

              Comment


              • #8
                Unable to know for sure, but since he only removed/installed the motor, there would be no reason to get behind the helm. It has to be by the motor somewhere

                There is more then one wire which is connected at the engine block with the negative cable, or on the other side of the block at the rear.

                Your motor fires up and all those gauges work fine. Gas does not, but gas isn't connected to the motor
                94 Formula 27PC Custom 509MPI MEFI3 , B3 XR
                95 Rinker 232 w/ 7.4L Carb 0F425011 B1 0F486471
                07 Seadoo GTX
                Merc Adults Only VP Adults Only
                G-Dad always said "First Liar doesn't stand a chance"

                Comment


                • #9
                  From memory when I R&R'd my 4.3. There are two grounds connected to the flywheel cover lower cap screws. On left/port is a continuity ground connecting transom assembly to the engine. Verify this is connected. It's important. The second was behind the starter. I think this was also a battery ground to engine block. If disconnected it could be your problem.
                  '96 Larson 174 SEI BR. 4.3LX 4 bbl Weber s/n 0F786604. Alpha One Gen II s/n 0F709315

                  Comment


                  • #10
                    Follow the negative battery cable to the motor. It will be bolted to the flywheel housing in most cases. Unbolt it and use a wire brush to make it perfectly clean and bright. Then make the motor side and the bolt clean and bright.

                    On my boat the hydraulic pump motor has its own power wire and ground direct from the battery. The solenoids on the pump are connected to the regular power system. Every boat has its own accessory wiring methods, so no one can tell you exactly where everything is.
                    17 Foot '90 Bluewater
                    Alpha 1 3.0 Merc - repowered in 2016
                    now - 4.3L Vortec - Alpha 1 GenII
                    Honda BF100L kicker
                    Engine custom - Transom 0D65328 - Drive 0D648864
                    If you ain't fishin, then yer working too much.

                    Comment


                    • #11
                      It appears that basically nothing is working right other than the starter , trim pump and speedo...
                      it has to be something simple but it’s eluding me...
                      if the main ground from the battery to the block was corroded or loose the starter wouldn’t turn correct?

                      Comment


                      • #12
                        Sign up today
                        Pull the 10 pin connector apart and check pins. You have a the main power (Red/Purple) and Ground (Black) and the pins may not be connecting properly

                        If there good your back to looking from what's disconnected

                        Many boats have extra wires attached to Neg/Pos terminals which feed everything

                        Mine has an extra Pos cable coming off battery switch that feeds electronics, also extra Neg off bass bar
                        94 Formula 27PC Custom 509MPI MEFI3 , B3 XR
                        95 Rinker 232 w/ 7.4L Carb 0F425011 B1 0F486471
                        07 Seadoo GTX
                        Merc Adults Only VP Adults Only
                        G-Dad always said "First Liar doesn't stand a chance"

                        Comment

                        Working...
                        X