Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse
No announcement yet.

2004 Suzuki DF140 (same as Johnson) water pump issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2004 Suzuki DF140 (same as Johnson) water pump issues


  • #2
    Re: 2004 Suzuki DF140 (same as Johnson) water pump issues

    Run a water hose up the water tube with the thermostats out and see if water is getting thru the powerhead; should come gushing out thru the thermo hole.

    Comment


    • #3
      Re: 2004 Suzuki DF140 (same as Johnson) water pump issues

      Do you mean the line I identified in the picture?Click image for larger version

Name:	Untitled.jpg
Views:	1
Size:	96.7 KB
ID:	7106087

      Comment


      • #4
        Re: 2004 Suzuki DF140 (same as Johnson) water pump issues

        Attach a water hose to the water tube that inserts into the top of the water pump. I use a clear vinyl tube with proper hose fitting on one end.
        This is done with the LU off, and you can run it that way.
        Will says do that, remove the thermos, or actually run the hose without the thermo cover on, to see if water gushes out.

        This will tell you if you have a blockage in the powerhead, or if the LU is actually not pumping.

        Comment


        • #5
          Re: 2004 Suzuki DF140 (same as Johnson) water pump issues

          take the impeller out and check the impeller hub is not spinning !!!!
          just because its new don't mean its not a bad rubber hub in the impeller.
          with a hose on the water piper going upto the engine you should see water coming out the peephole straight away.
          do check that the gasket on water pump is not bad also, again just because its new is not always 100%.
          have made double sure the key is in the impeller ? simple stupid thing to forget but ive done it myself.
          Ya cant fix stupid, coz there aint no cure

          Comment


          • #6
            Re: 2004 Suzuki DF140 (same as Johnson) water pump issues

            thanks guys, I will double check all of that tonight! I did double check it yesterday but I was so frustrated that I may have over looked some item. I will put the hose up the pump hole and go from there.

            thanks again

            Comment


            • #7
              Sign up today
              Re: 2004 Suzuki DF140 (same as Johnson) water pump issues

              Hey Guys,

              So last night I put the hose into the flush port and sure enough the water was flowing through the pee hole…put the ear muffs on…no PEE!

              So I decided to take of the LU and put the hose directly into the water port and pee whole pee’d again!! I figured it was the impeller at this point so I mounted the LU with a couple of bolts and all of a sudden it’s peeing but I did notice that the ear muffs have to be on perfectly as well…

              So either putting the hose in the hole un-clogged something…or that it’s the ear muffs that are sensitive but either way it’s pumping water!!!!

              Thanks for all of your help and comments.

              PS: While I was looking at this I figured I might as well change the thermostat on the engine…anyone know if it’s a 61c or 70c that comes in the engines by default?? Or recommendations?

              Comment

              Working...
              X