Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse

Private Messages

We are aware of a current issue where your messages screen does not properly load and we are working on a fix.

In the interim, you can access you messages by navigating to this link: https://forums.iboats.com/privatemessage/notification

Apologies for the inconvenience.
See more
See less

Spectrum 1706 throttles, but won’t shift

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spectrum 1706 throttles, but won’t shift

    Hey all. Newbie to these forums, and boating as well. Bought a Spectrum 1706 with Force 40 motor, late last year. Put in the water after purchase, and the throttle/shift worked fine. It also has the push button “throttle only” on it. Put it in the water today and used the throttle only button to warm up engine. Realeased button, and nothing but throttle. It will not shift at all, just throttles. Just wondering if there is a fix for this, or should I just consider a new unit.

    Thanks in in advance for any help.

  • #2
    Welcome aboard.

    Try moving handle forward and back through neutral. The button should pop out unless it's sticking.
    BOAT SPECS FORUM HELP STARCRAFT FORUM SHOP iboats
    Please, no PM's (Private Messages) regarding boat/engine problems.
    That is what the forums are for.
    Only forum/moderator issues will be answered in PM's.

    Comment


    • #3
      Thanks for the welcome. Tried moving the handle for quite a while. Button never came out. I was able to get the button off, but here is no resistance or spring tension on the pin under the button. It’s as if something has broken, but I can find zero info on these boats.

      Comment


      • #4
        Is the control a Force unit?

        There are so many different controls, so we need to ID your's.
        BOAT SPECS FORUM HELP STARCRAFT FORUM SHOP iboats
        Please, no PM's (Private Messages) regarding boat/engine problems.
        That is what the forums are for.
        Only forum/moderator issues will be answered in PM's.

        Comment


        • #5

          Comment


          • #6
            It's some version of a Quicksilver control. I'm not much help, but hope one of our smarter guys see the thread and can help.
            BOAT SPECS FORUM HELP STARCRAFT FORUM SHOP iboats
            Please, no PM's (Private Messages) regarding boat/engine problems.
            That is what the forums are for.
            Only forum/moderator issues will be answered in PM's.

            Comment


            • #7
              You can look through this to see if you find your control parts diagram. It's the best I can do for now.

              http://tinyurl.com/y2v4bbmw
              BOAT SPECS FORUM HELP STARCRAFT FORUM SHOP iboats
              Please, no PM's (Private Messages) regarding boat/engine problems.
              That is what the forums are for.
              Only forum/moderator issues will be answered in PM's.

              Comment


              • #8
                Thanks. Any help is better than none.

                Comment


                • #9
                  If I can get this apart, will there be any markings to identify what I have. Kinda looks like the commander 3000 series......sort of.

                  Comment


                  • #10
                    Sign up today
                    Any other suggestions? I’m at a total loss

                    Comment

                    Working...
                    X