Welcome Guest - Sign Up today
Welcome Guest - Sign Up today

Announcement

Collapse
No announcement yet.

IGN key doesn’t work

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • IGN key doesn’t work

    I need a little help. My ignition key doesn’t work anyone. My batteries are both fully charged. The blower, bilge pump, and trim all work well. When I turn the ignition key however, it’s completely dead. The gauges don’t come alive, and nothing is energized. Obviously the engine won’t start either.

    The boat oat is a 2007 Rinker Captiva with a merc 6.2L and bravo 3 drive. It’s been 100% reliable for years. It just sat covered in my driveway for 5 weeks.
    2005 Rinker Captiva 232
    Merc MAG 350 MPI
    Bravo III Drive 26P Merc SS Prop
    2016 Venture VATB-5225 Aluminum Trailer

    2005 GMC Yukon Denali Tow Vehicle
    2010 Chevy Camaro RS/SS Daily Driver

  • #2
    Its either the 20 amp ignition fuse, or the kill switch. The fuse/breaker comes off the red/purpple wire on the key switch, and kill switch breaks the purple wire
    94 Formula 27PC Custom 509MPI MEFI3 , B3 XR
    95 Rinker 232 w/ 7.4L Carb 0F425011 B1 0F486471
    07 Seadoo GTX
    Merc Adults Only VP Adults Only
    G-Dad always said "First Liar doesn't stand a chance"

    Comment


    • #3
      use a digital meter and start diagnosing.
      Cheesehead boating the Gulf Coast of FLA 27.51° N, 82.53° W

      1988 Cruisers Rogue 2420 -VP 290 DP now powered by custom 468 - https://forums.iboats.com/forum/owner...988-rogue-2420

      Past Boats
      1970 Wooster Hellion - Merc 9.8
      2002 SeaRay 190BR - 5.0 - A1G2 - "Cheeseheads in Paradise"
      1984 Avanti 170DLI -3.0 stringer- "Ship Happens"

      What’s behind you doesn’t matter.Enzo Ferrari

      Comment


      • #4
        Huge help so far. The red & purple wire is getting zero bolts at the key ignition switch. The IGN circuit breaker is in, and it’s getting zero volts there too.

        Where does the red & purple wire go in the engine bay? That must be where the disconnect is.
        2005 Rinker Captiva 232
        Merc MAG 350 MPI
        Bravo III Drive 26P Merc SS Prop
        2016 Venture VATB-5225 Aluminum Trailer

        2005 GMC Yukon Denali Tow Vehicle
        2010 Chevy Camaro RS/SS Daily Driver

        Comment


        • #5
          Again, Muchas Gracias to Alldodge & Scott Danforth.

          I traced the un-powered red & purple wire to a 50A circuit breaker in the engine bay, mounted on top of the engine itself, behind the air cleaner. That circuit breaker had a solid red wire going into it, and a red/purple exiting it. It apparently converted raw unprotected power into protected power leading to the helm.

          That circuit breaker was a little corroded and no longer holding itself closed. I cleaned it up and now everything works! Unfortunatley, I took apart half the interior chasing that wire.
          2005 Rinker Captiva 232
          Merc MAG 350 MPI
          Bravo III Drive 26P Merc SS Prop
          2016 Venture VATB-5225 Aluminum Trailer

          2005 GMC Yukon Denali Tow Vehicle
          2010 Chevy Camaro RS/SS Daily Driver

          Comment


          • #6
            Sign up today
            Been in the water floating and cooling off

            The solid red comes from the starter post and thru the 90 amp fuse. Since you have no power on the red or red/purple, then the 90 amp fuse blew. In most cases when it blows, a battery cable was put on wrong, there was a short somehow, or most probable is the alternator shorted out

            Click image for larger version

Name:	90 amp fuse.jpg
Views:	13
Size:	4.2 KB
ID:	10784864Click image for larger version

Name:	Starter connect.jpg
Views:	7
Size:	39.8 KB
ID:	10784865
            94 Formula 27PC Custom 509MPI MEFI3 , B3 XR
            95 Rinker 232 w/ 7.4L Carb 0F425011 B1 0F486471
            07 Seadoo GTX
            Merc Adults Only VP Adults Only
            G-Dad always said "First Liar doesn't stand a chance"

            Comment

            Working...
            X