Please note this thread has been inactive for 90 days. For the best results, please start a new thread.
Results 1 to 8 of 8
  1. #1
    Cadet
    Join Date
    Jun 2004
    Location
    SW Florida
    Posts
    13

    Default Yamaha 90 Oil Injection Failure

    I ran my 1993 Yamaha 90 today after about 3 months of storage. (Plenty of oil in the engine tank) The boat ran fine at high speed for a few minutes then the engine began to falter and died. My guages are very cloudy and hard to read so I don't know if any of the warning lights are working but I'm pretty sure it is not getting oil. (No Smoke) It will idle ok but after a few moments of mid speed it gets noisy. How can I check the oil flow? Since it still idles fine and runs for a few moments at higher speeds is there a chance I have not yet ruined this engine?

  2. #2
    Supreme Mariner
    Join Date
    Sep 2003
    Location
    Kitty Hawk NC
    Posts
    20,072

    Default Re: Yamaha 90 Oil Injection Failure

    hello did you bleed the system after storing it? have you ever cleaned the tank and tank filter? the only way to know is by dissasembly and inspection. overheat will cause the same symptoms. when was the last alarm circuit test done? the oil injection on a yamaha is about as bullet proof as you can make a piece of machinery,however it requires maint like everything else. and maint does not mean just add more oil.
    no tech questions by PM, they wont get answered.
    you have to be trusted by the people that you lie to .

  3. #3
    Cadet
    Join Date
    Jun 2004
    Location
    SW Florida
    Posts
    13

    Default Re: Yamaha 90 Oil Injection Failure

    No I did not bleed the system nor have I ever cleaned the tank. or filter. It's pumping great water preasure and does not feel hot to the touch and the heat alarm works good. Is there a hose that I can pull while at idle to see if oil is moving?

  4. #4
    Supreme Mariner
    Join Date
    Sep 2003
    Location
    Kitty Hawk NC
    Posts
    20,072

    Default Re: Yamaha 90 Oil Injection Failure

    hello I suspect rather than a precision blend failure we are dealing with a customer neglect failure. much more common than pump failures.somewhere in your service manual there is an oil consumption test. all the tests require the engine to have a 50-1 premix while running the test. I cannot remember the output specs but you unplug the hose downstream of any inline check valves,if used, and run the engine at the specified RPM for the specified time and collect the oil. the details are in the manual. but remember he pre mix while doing it.
    no tech questions by PM, they wont get answered.
    you have to be trusted by the people that you lie to .

  5. #5
    Cadet
    Join Date
    Jun 2004
    Location
    SW Florida
    Posts
    13

    Default Re: Yamaha 90 Oil Injection Failure

    Running the motor on 50:1 fuel I have removed a few oil lines but NO oil is flowing anywhere. Can someone explain the theory of opperation. What drives the pump?

  6. #6
    Master Chief Petty Officer
    Join Date
    Sep 2004
    Location
    Vancouver, British Columbia.
    Posts
    864

    Default Re: Yamaha 90 Oil Injection Failure

    its gear driven from the crankshaft.

  7. #7
    Petty Officer 1st Class
    Join Date
    Feb 2002
    Location
    Canada
    Posts
    298

    Default Re: Yamaha 90 Oil Injection Failure

    Time to purchase a workshop manual! Absolute must if you plan on doing your own maintenance.

  8. #8
    Commander Triton II's Avatar
    Join Date
    Nov 2004
    Location
    Oyster Point, Queensland, Australia
    Posts
    2,467

    Default Re: Yamaha 90 Oil Injection Failure

    Does the motor run properly on premix? If so it points to the oil pump not working... could be broken or just needs bleeding. After buying the manual as suggested, follow the bleed routine and do the test again. If still no oil flow it could be an airleak in the lines or a broken pump. I'm not an expert but had this problem a few years ago on a Yam 50 and it was because I hadn't bled the oiling system.
    TABS 580 Ocean Series - Sold!
    Yamaha F115 - Sold!
    Holden Rodeo LT crewcab ute - still going strong.

Similar Threads

  1. EFI vs oil injection failure diagnosis
    By brownfish in forum Mercury & Mariner Outboards
    Replies: 6
    Last Post: December 17th, 2006, 12:50 PM
  2. VRO / Other Oil Injection Systems Failure Data...
    By kmaglothin in forum Non-Repair Outboard Discussions
    Replies: 13
    Last Post: June 13th, 2004, 03:03 PM
  3. 98 200 EFI oil injection failure
    By brathbun in forum Mercury & Mariner Outboards
    Replies: 3
    Last Post: July 26th, 2003, 07:50 AM
  4. '99 250 Yamaha SWSII failure
    By benny914 in forum Yamaha & Suzuki Outboards
    Replies: 1
    Last Post: December 9th, 2002, 01:08 PM
  5. Oil injection pump failure?
    By dterwill in forum Mercury & Mariner Outboards
    Replies: 8
    Last Post: October 1st, 2002, 02:32 PM
  1. iboats Forum Directory - Over 100,000 forum posts organized by topic