Please note this thread has been inactive for 90 days. For the best results, please start a new thread.
Results 1 to 12 of 12
  1. #1
    Cadet
    Join Date
    Mar 2009
    Posts
    4

    Default Yamaha 3HP won't Rev under load

    I have a 1993 Yamaha 3HP (3MSHR) that starts fine, idles fine, revs up just fine in neutral, but will not rev up when in gear and in the water. I suspected the carb and took it off, found the needle valve had broken off in the orifice. Purchased the carb kit, had a machine shop remove the broken tip from the orifice, installed the new needle valve. Engine ran fine the first time out. Just like new. Next time out, same thing...will not rev in gear in the water. Any ideas?

  2. #2
    Moderator JB's Avatar
    Join Date
    Mar 2001
    Location
    The Hideout, Whitt, TX, USA
    Posts
    45,902

    Default Re: Yamaha 3HP won't Rev under load

    This needs to be in the Yamaha Forum, TR. I will move it.

  3. #3

    Default Re: Yamaha 3HP won't Rev under load

    I would say that you have a carb issue agian,It will probley need to be taken off and cleaned.How long does it sit up between running,Are you putting in fresh fuel?I would also check tank,filter and fuel lines running to carbs for trash.
    1996 16X48 Weldcraft with a 96' Yam60 hangin off the back SOLD. Went to MMI

  4. #4
    Petty Officer 3rd Class
    Join Date
    Feb 2009
    Posts
    75

    Default Re: Yamaha 3HP won't Rev under load

    Probally another Ethenol problem!!!!! Clean carb

  5. #5
    Cadet
    Join Date
    Mar 2009
    Posts
    4

    Default Re: Yamaha 3HP won't Rev under load

    Carb was first suspect. I have taken it off, stripped it down, boiled it out, replaced everything I can replace, no effect. Fresh fuel doesn't have any effect. Filters are new & clean. Good flow to the carb. I'm not a small engine mechanic so I may totally miss the obvious, but does this engine have "reeds" between the carb and the combustion chamber? Could that be a suspect?

    Thanks for your time and expertise!

  6. #6

    Default Re: Yamaha 3HP won't Rev under load

    Yes it does have reeds the reeds are located behind the plate that the carb bolts to its the two bolts that are off set behind the carbs,I dont think its that how was the fuel pump diaphram,it maybe electrical
    1996 16X48 Weldcraft with a 96' Yam60 hangin off the back SOLD. Went to MMI

  7. #7
    Cadet
    Join Date
    Mar 2009
    Posts
    4

    Default Re: Yamaha 3HP won't Rev under load

    Thanks for the advice. I just came in from bench running the Yamaha. Running it in neutral (of course) it seems to me that it gets real lean as it revs up. After idling back down, it runs smooth for about a minute, then "loads up" and is hard to get to rev again without using the choke for just a second. Once the RPM pick back up, it runs good again.

    I agree that something in the fuel path must be the culprit, but what? Its such a sweet little motor, it would be a shame not to get it running normally again. Thanks for all your good advice! It's helpful.

  8. #8

    Default Re: Yamaha 3HP won't Rev under load

    When you are tearing into the carbs and reassembleing are you using the same parts or did you pick up a carb kit,It could be leaking gaskets or Impropperly set metering screws.You need to be careful running if you suspect its running lean as you could fry a piston very easly.there could still be trash in the high speed circut in the carbs.Maybe Rodbolt will chim,He is the man with most the answers.
    1996 16X48 Weldcraft with a 96' Yam60 hangin off the back SOLD. Went to MMI

  9. #9
    Petty Officer 3rd Class
    Join Date
    Aug 2006
    Location
    Liberty, Tx
    Posts
    99

    Default Re: Yamaha 3HP won't Rev under load

    I had a 1995 175hp that would only take off if you primed it after it was warmed up. Would idle all day long. Took it to a dealer and they told me that it wasn't advancing the timing on take off. Don't know if the Yamaha is the same but just an idea.

  10. #10
    Petty Officer 3rd Class
    Join Date
    Feb 2009
    Posts
    75

    Default Re: Yamaha 3HP won't Rev under load

    How long did this engine sit after the 1st initial run????????

  11. #11
    Cadet
    Join Date
    Mar 2009
    Posts
    4

    Default Re: Yamaha 3HP won't Rev under load

    Thanks for all the helpful suggestions! I think I have narrowed it down to either a leaky gasket at the fuel pump or a faulty fuel pump. Here's how I arrived at this premise;

    When I start the engine, I am using the choke. The suction of the intake is helping to pull fuel through the carb. Once the engine starts, I push the choke in and the engine is able to idle. As I increase throttle, the engine starves for fuel and dies. I have found that I can manipulate the choke and gain throttle. I believe the application of the choke is "sucking" fuel through the fuel pump and supplying the fuel for combustion using the suction of the intake.

    What I plan to do: Take the carb off one more time, get a kit to replace whatever diaphram is in the fuel pump and every gasket in the whole assembly. Replace the needle valves (again) and re-assemble. Then at least I will have eliminated several suspects.

  12. #12

    Default Re: Yamaha 3HP won't Rev under load

    Post back if thats what helps.That way it may help others.
    1996 16X48 Weldcraft with a 96' Yam60 hangin off the back SOLD. Went to MMI

Similar Threads

  1. Won't rev under Load
    By Equis in forum Johnson & Evinrude Outboards
    Replies: 6
    Last Post: November 30th, 2008, 05:20 AM
  2. 15 hp evenrude won't rev under load
    By cdwill007 in forum Johnson & Evinrude Outboards
    Replies: 22
    Last Post: July 22nd, 2007, 07:47 AM
  3. Sears 3HP - dies under load
    By watercruiser in forum Other Outboard Brands
    Replies: 3
    Last Post: August 9th, 2005, 08:40 AM
  4. 1986 Mariner 90 HP won't REV Up under load
    By Bob Blair in forum Mercury & Mariner Outboards
    Replies: 2
    Last Post: July 18th, 2002, 04:39 AM
  5. Mariner Will not rev under load
    By 85Mariner in forum Mercury & Mariner Outboards
    Replies: 1
    Last Post: May 24th, 2002, 02:25 AM
  1. iboats Forum Directory - Over 100,000 forum posts organized by topic