Please note this thread has been inactive for 90 days. For the best results, please start a new thread.
Results 1 to 7 of 7
  1. #1

    Default Yamaha 115 Oil Injection Problem

    After 18 years of trouble free operation, my 1985 Yamaha 115 ETLK is continuously pumping oil from the sub oil tank to the main oil tank, causing the engine to exhaust a tremendous amount of smoke as well as leaking oil into the engine compartment. The pump delivered a gallon of oil in just one afternoon of operation. Could this be caused by a faulty oil level sensor? If so, can it be cleaned or does it require replacement?

  2. #2
    Commander
    Join Date
    Jul 2002
    Location
    Nelson Marine Service, Panama City Bch, Fl
    Posts
    2,108

    Default Re: Yamaha 115 Oil Injection Problem

    One thing for certain, the pump in the main tank works just fine. Remove the float from the remote tank on the engine. Slide the float to the bottom and see if you get an alarm. Then slide it up a bit and the pump should kick on. Slide it to the top and the pump should kick off. If it passes this test, then the float isn't floating properly. To check the float, disconnect the plug and insert an ohm meter probe in the hole with the black wire. With the float at the top, you should get continuity between the black wire and white. with the float in the center, continuity between black and brown and at the bottom continuity between black and red. If it passes this test, then the control module is bad.

  3. #3
    Cadet
    Join Date
    Sep 2003
    Location
    Olympia, WA
    Posts
    3

    Default Re: Yamaha 115 Oil Injection Problem

    Same thing happenned to my 1988 115 HP. The probelm was the high level switch wasn't working, so the side mounted reservoir just kept overfilling. Lots of oil around the base of the engine compartment and oil vapor that got sucked in through the air intake caused the engine to run very rough. The local shop told me that Yamaha doesn't make parts for that motor anymore and he had to call around to see if anyone had the part. Based on what is going on now, I wish I had gotten rid of it last year. Look for it under Dougbren

  4. #4
    Supreme Mariner
    Join Date
    Sep 2003
    Location
    Kitty Hawk NC
    Posts
    20,072

    Default Re: Yamaha 115 Oil Injection Problem

    Hello I cant think of any oil system parts that are not avalible for the 115. when the engine oil tank overflows the small vent line that is routed from the tank top to the airbox transfers oil to the airbox and the bottom carb swims in oil. normally one of two problems. one is the engine oil level sensor is bad and two the control module went bad. there is a link someone posted on this site about trouble shooting this system that is very complete. almost as complete as what yammy school gives us. good luck
    no tech questions by PM, they wont get answered.
    you have to be trusted by the people that you lie to .

  5. #5
    Commander
    Join Date
    Jul 2002
    Location
    Nelson Marine Service, Panama City Bch, Fl
    Posts
    2,108

    Default Re: Yamaha 115 Oil Injection Problem

    Doug, I would find another shop. Its evident that they are just lazy. Yamaha has tons of parts for their engines all the way back to the first in 84. Now parts for the sterndrive, that's another subject.

  6. #6

    Default Re: Yamaha 115 Oil Injection Problem

    Capt. Ken, thanks for the detailed troubleshooting information. I followed your instructions for testing the float and the results surprised me. I was not expecting continuity between the black and white wires with the float at the top position. What I found was: It had continuity in the top position between the black and white wires. It had continuity in the middle position between the black and brown wires. It didn’t have continuity in the bottom position between the black and red wires.When the float was in the bottom position, the alarm sounded with the red warning light displayed. When the float was in the middle position, the yellow light was displayed. In the top position, the green light was displayed. It would seem likely that the oil level sensor would stop the pump from overflowing the tank since the top position on the oil level sensor passed the continuity test. It was the bottom position that failed the test.I disassembled and cleaned the oil level sensor and moved the float along the shaft and the results were the same. I reassembled the oil level sensor and the results were the same. I also noticed that whenever the ignition switch is in the on position, the pump runs continuously.Would you recommend replacing the control module or the oil level sensor?

  7. #7
    Supreme Mariner
    Join Date
    Sep 2003
    Location
    Kitty Hawk NC
    Posts
    20,072

    Default Re: Yamaha 115 Oil Injection Problem

    Hello sounds like you are narrowing the problem down. after 18 years why not just replace both the control unit and the level sensor. neither are that expensive if you can lower the float all the way and get an alarm you resistance reading was faulty. yamaha uses closed circuits to ground for all triggering functions. once the sub oil tank pump is triggered to on the white wire going to the contol module can be grounded and the pump should stop if it does not the module is bad. anyway its simple to just replace them both. make sure you retrived the old stainer seal and use a new one on final assy. also the vent hole for the stainer MUST be over the flat in the rubber part of the sensor on reassy. Good luck and keep posting
    no tech questions by PM, they wont get answered.
    you have to be trusted by the people that you lie to .

Similar Threads

  1. 1987 Yamaha 115 oil injection problem
    By imported_tigger in forum Yamaha & Suzuki Outboards
    Replies: 3
    Last Post: August 5th, 2006, 09:41 PM
  2. Yamaha oil injection problem
    By fastkenny in forum Yamaha & Suzuki Outboards
    Replies: 2
    Last Post: October 12th, 2004, 05:22 AM
  3. Yamaha Oil Injection Problem
    By RangerJer in forum Yamaha & Suzuki Outboards
    Replies: 28
    Last Post: September 3rd, 2004, 02:06 PM
  4. YAMAHA 250 Oil Injection Problem
    By freeman-c in forum Yamaha & Suzuki Outboards
    Replies: 2
    Last Post: May 20th, 2003, 04:36 PM
  5. yamaha 150 oil injection problem
    By jig in forum Yamaha & Suzuki Outboards
    Replies: 5
    Last Post: May 18th, 2003, 08:44 PM
  1. iboats Forum Directory - Over 100,000 forum posts organized by topic