Please note this thread has been inactive for 90 days. For the best results, please start a new thread.
Results 1 to 7 of 7
  1. #1

    Default Trailer brake and turn lights work but not running lights

    My turn signals and brake lights work but not the running lights or sidemarker lights. Where should I start?

  2. #2
    Seaman cheetah90's Avatar
    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    60

    Default Re: Trailer brake and turn lights work but not running lights

    Try checking/cleaning the ground "white wire", clean your plug. start there and see if that helps.

  3. #3
    Petty Officer 2nd Class hoytvectrix's Avatar
    Join Date
    Jul 2009
    Location
    Villa Ridge, MO
    Posts
    114

    Default Re: Trailer brake and turn lights work but not running lights

    clean the ground, also check for shorts in the brown wire, that is the wire for the running lights. Also check your brown wire at the truck side to make sure there aren't any shorts.
    16x52 Blazer flat bottom with 50/35 yamaha jet
    2096 polar craft with 90 Evinrude E-TEC
    16' Lowe flat bottom
    64 johnson 9.5
    65 evinrude 9.5

  4. #4
    Petty Officer 1st Class
    Join Date
    Aug 2002
    Location
    Charlottesville,VA
    Posts
    363

    Default Re: Trailer brake and turn lights work but not running lights

    What is the tow vehicle??? Ford trucks (F150's and Expeditions) have a separate fuse in under hood fuse box which just powers the trailer marker/running lights.

  5. #5
    Petty Officer 2nd Class dirtdiver's Avatar
    Join Date
    May 2010
    Location
    Watertown Ny / Pittsburgh PA
    Posts
    118

    Default Re: Trailer brake and turn lights work but not running lights

    I think all F150s are like that, I have a 2010. Sure enough the fuse was blow and there was a short in the running lights.

  6. #6

    Default Re: Trailer brake and turn lights work but not running lights

    Yea I have an F150 too so I'll definitely have to check the running lights.

  7. #7

    Wink Re: Trailer brake and turn lights work but not running lights

    I had the same problem. I found out it was a blown fuse. Checked the fuses
    under the hood and found a bad one. Replaced that and brought back my turn signals. Still couldn't get my running lights working. After checking further I found out there is another fuse box under the drivers side rear seat.
    Checked there to find another fuse out. That fuse was for the running lights.
    I have a 2004 GMC SUV. Check at your rear plug to see if your problem isn't comming from the vehicle.

    Raptorman

Similar Threads

  1. Running lights not working on my four flat trailer lights
    By 16' of therapy in forum Trailers and Towing
    Replies: 27
    Last Post: September 27th, 2010, 11:13 AM
  2. Driving lights but no brake or turn signals?
    By imthemedic in forum Trailers and Towing
    Replies: 12
    Last Post: June 20th, 2010, 11:12 PM
  3. Replies: 6
    Last Post: June 16th, 2010, 11:15 AM
  4. running lights on trailer wont work
    By jstill in forum Trailers and Towing
    Replies: 5
    Last Post: February 10th, 2009, 07:50 AM
  5. trailer brake lights question-they're not working
    By ramairguy in forum Trailers and Towing
    Replies: 5
    Last Post: March 28th, 2006, 12:18 PM
  1. iboats Forum Directory - Over 100,000 forum posts organized by topic