Please note this thread has been inactive for 90 days. For the best results, please start a new thread.
Results 1 to 3 of 3
  1. #1
    Seaman
    Join Date
    Aug 2007
    Posts
    57

    Default Sears Ted Williams 7.5

    I just purchased a sears ted williams 7.5. i've read the threads and understand the risks with this motor, it does have the electronic ignition....however, this motor has good spark and looks close to new so I figure the $90 price was a calculated risk. And yes, I like to tinker......

    My question, can someone tell me the year? Numbers are:
    model: 217-58820
    ser#: 153627

    Mix is 32:1 correct? It said don't use unleaded gas but have no choice....is that a concern?

    Thanks..........John

  2. #2
    Seaman
    Join Date
    Aug 2007
    Posts
    57

    Default Re: Sears Ted Williams 7.5

    UPDATE.......turned out this was $90 well invested(so far). Yesterday evening I pulled and cleaned the carb.....it was full of oil???? I'm guessing the gas evaporated and the oil was left behind??, the motor hadn't been run in over 4 years.... Anyways, cleaned the carb up good, changed lower unit oil and reassembled. Put the motor in a bucket and it started on 5 pulls and runs great. Good spray coming from the leg but will order and replace the impeller anyway. Starts on 1 pull now......I will test it on my inflatable this afternoon.........so far so good.......

  3. #3

    Default Re: Sears Ted Williams 7.5 not getting fuel?

    Hello, this is my first time here but I've picked up a lot of good info while reading different posts. I have a '73 Ted Williams 7.5 hp It was running fine but one day on the water, it just cut out at low speed. Took a while to get it running but when I did, it wouldn't run for long. Took the carb apart and found the pump/element was split. Ordered one, replaced it, even put it in at a 45 degree angle (which I learned was the proper way on this forum, thanks) replaced gasket also. It started right up, thought I had it, but it cut out again. Checked the gas line from aux. tank for holes, nothing. The thing purrs like a kitten using the on-board tank but not the aux. tank so I'm guessing it's not pumping enough to pull gas from that tank. Also, I noticed there was no needle seat in the carb, why does it run so good on the on-board tank without it? Any tips would help, thanks!

Similar Threads

  1. Sears Ted Williams 9.9HP
    By toadfuss in forum Other Outboard Brands
    Replies: 11
    Last Post: March 14th, 2010, 08:53 AM
  2. 7hp sears ted williams
    By Ironmike in forum Other Outboard Brands
    Replies: 11
    Last Post: May 9th, 2007, 07:54 PM
  3. Sears Ted Williams
    By Ironmike in forum Other Outboard Brands
    Replies: 5
    Last Post: April 18th, 2007, 05:20 PM
  4. Sears Ted Williams 5.5 HP
    By saltydwg in forum Other Outboard Brands
    Replies: 1
    Last Post: May 20th, 2006, 04:59 PM
  5. Sears Ted Williams 7.5 HP
    By Rob Thorp in forum Other Outboard Brands
    Replies: 5
    Last Post: August 3rd, 2004, 08:23 PM
  1. iboats Forum Directory - Over 100,000 forum posts organized by topic