Please note this thread has been inactive for 90 days. For the best results, please start a new thread.
Results 1 to 5 of 5

Thread: rust problem

  1. #1
    Petty Officer 1st Class hitace's Avatar
    Join Date
    May 2007
    Location
    maryland
    Posts
    390

    Default rust problem

    i noticed a small amount of rust on the plate under the outboard whats the best way to stop or at least slow down the rust process.thanks.

  2. #2
    Honorary Moderator Emeritus tashasdaddy's Avatar
    Join Date
    Nov 2005
    Location
    Jacksonville, Florida
    Posts
    51,017

    Default Re: rust problem

    clean sand paint.
    FLORIDA GATORS
    TEBOW Country



    Please, NO PM's (Private Messages) regarding boat/engine problems. they will not be answered.
    That is what these forums are for. Post your questions, in the appropriate Forum.

  3. #3
    Petty Officer 1st Class hitace's Avatar
    Join Date
    May 2007
    Location
    maryland
    Posts
    390

    Default Re: rust problem

    what kind of paint should i use?how should i clean it?

  4. #4
    Petty Officer 2nd Class
    Join Date
    Mar 2005
    Location
    San Francisco
    Posts
    124

    Default Re: rust problem

    During every tune-up, about once a year, I spray 90 weight oil in a paint sprayer, on the steel parts. It lasts pretty good,

  5. #5
    Petty Officer 1st Class hitace's Avatar
    Join Date
    May 2007
    Location
    maryland
    Posts
    390

    Default Re: rust problem

    thanks

Similar Threads

  1. towing with GM truck BIG rust problem
    By tommays in forum Trailers and Towing
    Replies: 6
    Last Post: June 3rd, 2005, 05:42 AM
  2. Rust problem
    By nightvision in forum Trailers and Towing
    Replies: 8
    Last Post: February 21st, 2005, 02:58 PM
  3. Rust
    By Mr.Ladyfish in forum Boat Topics and Questions (not engine topics)
    Replies: 2
    Last Post: December 3rd, 2003, 07:30 AM
  4. Rust on tilt/trim problem
    By bryanredfish in forum Mercury & Mariner Outboards
    Replies: 1
    Last Post: August 20th, 2003, 04:27 AM
  5. Ack! Rust!
    By C17LoadSmasher in forum Mercruiser I/O & Inboard Engines & Outdrives
    Replies: 4
    Last Post: April 14th, 2003, 10:02 AM
  1. iboats Forum Directory - Over 100,000 forum posts organized by topic