Please note this thread has been inactive for 90 days. For the best results, please start a new thread.
Results 1 to 14 of 14
  1. #1

    Default primer bulb wont fill up

    1985 50hp mercury idles fine, starts fine, no wot but it picks up when i squeeze the primer but then the primer wont fill back up till i bring it back to idle, it has a new portable gas tank and the primer and lines to the engine are new(bought this year) it has ran this way since day one, any suggestions?

  2. #2
    Master Chief Petty Officer
    Join Date
    May 2010
    Posts
    831

    Default Re: primer bulb wont fill up

    Is the gas tank vent open and working? Try it with the gas cap off.

  3. #3

    Default Re: primer bulb wont fill up

    i tried it with the vent opened a little and opened a lot and with the cap off same thing it has a mercury fitting next to the engine and an omc fitting at the tank probably makes no difference huh

  4. #4
    Master Chief Petty Officer
    Join Date
    May 2010
    Posts
    831

    Default Re: primer bulb wont fill up

    Did you replace the entire fuel line or just the part between the bulb and motor?

  5. #5

    Default Re: primer bulb wont fill up

    everything is new from the tank(including the tank) to where the line hooks the the engine

  6. #6
    Commander
    Join Date
    Apr 2007
    Location
    Michigan
    Posts
    2,112

    Default Re: primer bulb wont fill up

    Have you tried running the motor with the cowl/ hood off, to see if gas is spilling out of carbs/lines etc.?
    You probably looking at a fuel pump rebuild.

  7. #7
    Petty Officer 1st Class roncoop75's Avatar
    Join Date
    Jun 2010
    Location
    Omaha, NE
    Posts
    229

    Default Re: primer bulb wont fill up

    New primer bulb eh?

    You get that from walmart?

    The one I got from there didn't work, brand new and junk right from the start.

    If your old bulb isn't falling apart try putting it back in and see what happens.

    For the record I'm leaning towards fuel pump also. Don't be discouraged though, they're so easy to rebuild a cave man could do it!
    16' 1964 Duracraft runabout.
    90hp 1985 Merc I6.
    14' 1982 Lowe.
    18hp 1985 Merc. with a sick switch pack.

  8. #8
    Ensign
    Join Date
    Apr 2010
    Location
    Sydney Australia
    Posts
    947

    Default Re: primer bulb wont fill up

    Got the arrow on the primer bulb pointing in the right direction of flow?
    They also work better pointing upwards too.

  9. #9
    Commander
    Join Date
    Apr 2007
    Location
    Michigan
    Posts
    2,112

    Default Re: primer bulb wont fill up

    that was what I thought. primer bulb installed backwards.
    Also don't buy walmart/Kmart crap. Buy only OEM PARTS.

  10. #10

    Default Re: primer bulb wont fill up

    yes it is walmart will try something else

  11. #11

    Default Re: primer bulb wont fill up

    got the carbs built and now no trouble except real slow taking off prop pitch is 10 on a 16 ft bayliner 1040lbs 50 horse mercury is that about right?

  12. #12
    Seaman Apprentice
    Join Date
    Aug 2010
    Posts
    30

    Default Re: primer bulb wont fill up

    Forget Walmart, KMart, Meiers, and go to a real boat/motor outfitter and get a real motor. Look into anything but a Merc.

  13. #13

    Default Re: primer bulb wont fill up

    Once again, the above poster gives incredibly intelligent & helpful advice.

    I'm glad you got it running, Jason. My 15' Renken with the same motor takes of slowly. I have a 13 pitch prop. I think it's more an issue of power. 50hp isn't that much...I trimmed mine differently (it's manual trim) and I got it to pop out of the water better. Maybe you could try messing with the trim and see what happens.

  14. #14
    Banned
    Join Date
    Sep 2007
    Location
    charlotte nc
    Posts
    1,784

    Default Re: primer bulb wont fill up

    Quote Originally Posted by Mi duckdown View Post
    that was what I thought. primer bulb installed backwards.
    Also don't buy walmart/Kmart crap. Buy only OEM PARTS.
    Never seen that happen before. One of the little things that can be missed will be missed from time to time I guess.

Similar Threads

  1. Primer bulb or no primer bulb on EFI's
    By Bugsy's Baits in forum Mercury & Mariner Outboards
    Replies: 2
    Last Post: July 13th, 2009, 02:53 PM
  2. primer bulb
    By golfes in forum Mercury & Mariner Outboards
    Replies: 9
    Last Post: March 4th, 2006, 09:13 AM
  3. New Question - Primer ball does not fill
    By huminski in forum Johnson & Evinrude Outboards
    Replies: 12
    Last Post: October 16th, 2004, 07:09 AM
  4. primer bulb
    By skmurphy71 in forum Johnson & Evinrude Outboards
    Replies: 13
    Last Post: September 10th, 2004, 07:49 PM
  5. primer bulb
    By Ilikesalmon in forum Johnson & Evinrude Outboards
    Replies: 1
    Last Post: September 5th, 2004, 11:48 AM
  1. iboats Forum Directory - Over 100,000 forum posts organized by topic