Please note this thread has been inactive for 90 days. For the best results, please start a new thread.
Results 1 to 2 of 2
  1. #1

    Default 2006 Mercury 2 stroke 50hp power trim problem

    i'm having an issue with the power trim "leaking" down when the motor is trimed up and i power up. I've replaced the manual relief valve and didn't seem to help.......any suggestions, thank you

  2. #2
    Captain
    Join Date
    Mar 2006
    Location
    Cape Coral, FL
    Posts
    3,320

    Default Re: 2006 Mercury 2 stroke 50hp power trim problem

    try shimming the bypass spring inside of part # 827672A1. If that does not fix it then there are no easy answers.

Similar Threads

  1. 2005 Mercury 60HP EFI 4-Stroke Power Trim Problem
    By er-e-is in forum Mercury & Mariner Outboards
    Replies: 3
    Last Post: May 24th, 2011, 04:08 PM
  2. 2006 Mercury 90 HP 4-stroke idle problem
    By ibcaveman in forum Mercury & Mariner Outboards
    Replies: 0
    Last Post: August 19th, 2010, 04:09 PM
  3. 2006 Mercury 4-stroke efi runs with loss of power.
    By daveaok in forum Mercury & Mariner Outboards
    Replies: 0
    Last Post: August 18th, 2010, 04:49 PM
  4. 2006 Mercury 50HP Two-Stroke Overheat alarm
    By hatfieldm in forum Mercury & Mariner Outboards
    Replies: 1
    Last Post: May 24th, 2010, 11:02 PM
  5. 2006 Mercury 50HP Four Stroke Overheats
    By longshanks in forum Mercury & Mariner Outboards
    Replies: 5
    Last Post: June 14th, 2007, 02:41 PM
  1. iboats Forum Directory - Over 100,000 forum posts organized by topic