Please note this thread has been inactive for 90 days. For the best results, please start a new thread.
Results 1 to 5 of 5
  1. #1

    Default 1977 glastron motor wont trim

    I've got a 1977 glastron with a mercury850(pretty sure its a 75). the trim pump runs and wil pull the motor down, but wont lift it. I am pretty sure it has air on it but cant figure out how to bleed the air off.

  2. #2

    Default Re: 1977 glastron motor wont trim

    Never mind I got it figured out

  3. #3
    Rear Admiral Plainsman's Avatar
    Join Date
    Apr 2006
    Location
    From the panhandle of Nebraska
    Posts
    4,081

    Default Re: 1977 glastron motor wont trim

    What was the answer?
    Rest in Peace Spinner

    2010 Lowe FM 175 with a 2010 115 Mercury
    ------------------------------------------------
    Your friend,your partner, your defender,your dog.You are his life, his love, his leader. He will be yours, faithful and true, to the last beat of his heart. You owe it to him to be worthy of such devotion....by E.F. Henry

  4. #4

    Default Re: 1977 glastron motor wont trim

    i FOUND THE FILL PLUG ON THE FRONT RIGHT SIDE AND IT WAS LOW ON FLUID. I FILLED IT WITH ATF, AND THEN RAN THE TRIM UP AND DOWN WORKING THE AIR OUT THROUGH THE BLEEDERS ON THE TOP OF THE HYDRAULIC ARMS ON THE MOTOR. DOING THIS A FEW TIMES AND THE MOTOR STARTED LIFTING. DON'T KNOW IF IT WAS THE IGHT WAY, BUT I KNEW HOW TO BLEED A SNOW PLOW PUMP, AND I WORKED ON THIS

  5. #5
    Supreme Mariner
    Join Date
    Mar 2004
    Location
    On Barnegat Bay, NJ
    Posts
    17,576

    Default Re: 1977 glastron motor wont trim

    Manwithkids, There is another bleed screw on those rams. It is located next to where the hoses connect (inside middle of ram). You need to remove the rams from the motor and face the bleed screw up, remove it and run the trim motor to bleed the balance of the system.

Similar Threads

  1. Tilt Trim 1977 115hp Mercury trim motor spins only
    By 115merc in forum Mercury & Mariner Outboards
    Replies: 5
    Last Post: June 26th, 2007, 10:36 AM
  2. 1977 Glastron-Carlson CVZ-18 Shifting Problems
    By APickering in forum Glastron Boats
    Replies: 1
    Last Post: October 9th, 2006, 06:45 PM
  3. 1977 Glastron Sea Fury Top Speed
    By ben239 in forum Boat Topics and Questions (not engine topics)
    Replies: 0
    Last Post: September 3rd, 2004, 05:03 PM
  4. 1977 Glastron SSV 189
    By foragedata in forum Boat Topics and Questions (not engine topics)
    Replies: 4
    Last Post: July 29th, 2003, 08:14 PM
  5. 1977 85 hp v4 evinrude power trim motor
    By HBF4 in forum Johnson & Evinrude Outboards
    Replies: 2
    Last Post: December 27th, 2002, 09:23 AM
  1. iboats Forum Directory - Over 100,000 forum posts organized by topic