Please note this thread has been inactive for 90 days. For the best results, please start a new thread.
Results 1 to 14 of 14
  1. #1
    Admiral ziggy's Avatar
    Join Date
    Jun 2004
    Location
    Lincoln, NE. Branched Oak Lake
    Posts
    7,152

    Default trim won't work, 2011 glastron mx185

    my neighbor just got himself a brand spankin new boat. zero hrs..
    it's got a mercruiser 190 hp v6, genII drive.

    he'd like to go boating but guess the dealer let him down.
    he took it to the lake the other day. he steered to starboard and the boat went to port. visa versa obviously. took it back to the dealer. they fixed that. but now the trim is inop. worked prior to the steering fix.
    surely they left a wire loose or something. w/o anything to go by and just looking. nothing just jumps out at ya as to what may not be connected. what fuses that look like possibility all appear good.

    any ideas as to which wire got removed when the steering was serviced?
    trim button is totally inop. no nothing... drive is up all the way..
    'Lime Time'
    1975 AristoCraft Nineteen
    Mercruiser 165hp (chevy 250 L6), MC-1 drive

  2. #2
    Lieutenant Junior Grade
    Join Date
    Apr 2011
    Posts
    1,213

    Default Re: trim won't work, 2011 glastron mx185

    They (the dealer) should be open tomorrow! I can picture several different things. Mainly I'm thinking behind the dash. What does work, i.e. blower, bilge pump, nav lites, etc?

  3. #3
    Admiral ziggy's Avatar
    Join Date
    Jun 2004
    Location
    Lincoln, NE. Branched Oak Lake
    Posts
    7,152

    Default Re: trim won't work, 2011 glastron mx185

    They (the dealer) should be open tomorrow!
    yep, neighbor says they are, but the time frame don't work with his work schedule.
    What does work, i.e. blower, bilge pump, nav lites, etc?
    every thing works except the tirm. neighbor says he tried everything else and all is ok other than the trim.
    Mainly I'm thinking behind the dash.
    me too. i'm on the assumption (i know, i know, if i'm wrong correct me) that the steering error was at the helm. therefor it was what was disassembled. a wire didn't get hooked back up inadvertently. that's my guess anyways. there are several wires free under dash but no easy apparently place to put the extra ones.
    'Lime Time'
    1975 AristoCraft Nineteen
    Mercruiser 165hp (chevy 250 L6), MC-1 drive

  4. #4
    Honorary Moderator Emeritus Don S's Avatar
    Join Date
    Aug 2004
    Location
    Western WA.
    Posts
    62,323

    Default Re: trim won't work, 2011 glastron mx185

    "Does't work" can mean a lot of things. Does it make any noise at all? If so, what kind? Clicks, groans, moans buzz. bang. Get the idea?
    Where is the trim/tilt switch located?
    Don S.


    Please, no PM's (Private Messages) regarding boat/engine problems.
    That is what the forums are for.
    Only forum/moderator issues will be answered in PM's.

  5. #5
    Lieutenant Junior Grade
    Join Date
    Apr 2011
    Posts
    1,213

    Default Re: trim won't work, 2011 glastron mx185

    That fiqures, that the dealer is closed.
    Test the pump to make sure it has power & ground. If not check battery connections. They usually miss a cable or 2. Start there, I'll ck back.

  6. #6
    Admiral ziggy's Avatar
    Join Date
    Jun 2004
    Location
    Lincoln, NE. Branched Oak Lake
    Posts
    7,152

    Default Re: trim won't work, 2011 glastron mx185

    Does it make any noise at all?
    no.
    If so, what kind?
    it does nothing when the switch is energized, up or down.
    Clicks, groans, moans buzz. bang.
    nothing. silent. no power. imho.
    Get the idea?
    yep.
    Where is the trim/tilt switch located?
    at the top of the handle on the remote. like a 3000 i think. certainly not a 3000 though. rocker switch. up and down.

    That fiqures, that the dealer is closed.
    they're open. just 60 miles away + don't meet the owners work schedule demands.
    Test the pump to make sure it has power & ground.
    imho. it's missing one or the other.
    If not check battery connections. They usually miss a cable or 2. Start there,
    seems like a good idea. i'm confused by his batt. connections. there are extra wires that appear aftermarket. multiple connections at the batt. neg. and batt. positive. i wouldna thought that a brand new boat would have had clean pos. and neg. terminals. even my '75 is clean. 1 wire to ea. connection. his has multiple wires going to both. why, i don't know.
    'Lime Time'
    1975 AristoCraft Nineteen
    Mercruiser 165hp (chevy 250 L6), MC-1 drive

  7. #7
    Honorary Moderator Emeritus Don S's Avatar
    Join Date
    Aug 2004
    Location
    Western WA.
    Posts
    62,323

    Default Re: trim won't work, 2011 glastron mx185

    If installed by the book, Merc wants the trim pumps main wires attached directly to the battery. Many times the positive ends up on a switch, but the negative still needs hooked to the battery to work.
    Don S.


    Please, no PM's (Private Messages) regarding boat/engine problems.
    That is what the forums are for.
    Only forum/moderator issues will be answered in PM's.

  8. #8
    Lieutenant Junior Grade
    Join Date
    Apr 2011
    Posts
    1,213

    Default Re: trim won't work, 2011 glastron mx185

    Manufacturers never do the same thing as somebody else. Red is still positive (+). Black is ground (-) & so is yellow, as of 5-6 years ago. Look for 3-4 wires to (+). Big cable to starter, smaller heavy wire to trim pump, 1-2 small gauge like 14ga. Those 2 may have inline fuses wired into them. How many wires/cables are left?

    Edit; Check the plug at the pump itself. Round with 3 male spaes inside. Also the 20amp fuse in the J-clip.

    Don, I haven't seen to many manufacturers (boat) do anything "by the book" for 30yrs!

  9. #9
    Honorary Moderator Emeritus Don S's Avatar
    Join Date
    Aug 2004
    Location
    Western WA.
    Posts
    62,323

    Default Re: trim won't work, 2011 glastron mx185

    Don, I haven't seen to many manufacturers (boat) do anything "by the book" for 30yrs!
    I have, actually most of the time. Where things change is when the buyer wants extra batteries, or a switch, or ......... then things start changing with what the dealer does.
    Don S.


    Please, no PM's (Private Messages) regarding boat/engine problems.
    That is what the forums are for.
    Only forum/moderator issues will be answered in PM's.

  10. #10
    Lieutenant Junior Grade
    Join Date
    Apr 2011
    Posts
    1,213

    Default Re: trim won't work, 2011 glastron mx185

    I totally agree! But when a pays the better part of 30K for a boat that steers backwards! I thought I would start with the basics!

  11. #11
    Honorary Moderator Emeritus Don S's Avatar
    Join Date
    Aug 2004
    Location
    Western WA.
    Posts
    62,323

    Default Re: trim won't work, 2011 glastron mx185

    That starts at the manufacturer. they installed the steering.
    Shame on the dealer for not checking all systems prior to deliver,
    and shame on the buyer for not taking a trial run with the dealer to learn the boat and make sure it works.
    and shame on the buyer for not taking a test run before buying a boat.
    Don S.


    Please, no PM's (Private Messages) regarding boat/engine problems.
    That is what the forums are for.
    Only forum/moderator issues will be answered in PM's.

  12. #12
    Lieutenant Junior Grade
    Join Date
    Apr 2011
    Posts
    1,213

    Default Re: trim won't work, 2011 glastron mx185

    I hope he responds to the CSI survey's "Honestly"! And make things uncomfortable for the dealer!

  13. #13
    Admiral ziggy's Avatar
    Join Date
    Jun 2004
    Location
    Lincoln, NE. Branched Oak Lake
    Posts
    7,152

    Default Re: trim won't work, 2011 glastron mx185

    thanks for the ideas. if i see the neighbor out with his cover off this morning i'll go down and see what we can find.
    looks like the neighbor might not need his boat today too.
    looks like rain,.
    40% chance of rain,.

    i think i'll go and prep my boat for going out.. watching for rain to ruin my day.

    if it rains today, the neighbor can take it to the dealer tomorrow and let them uncluster it i guess...

    fwiw. the attachment looks very much like what he may have. trim pump looks the same, remote looks the same, except his is side mount. solenoids look similar..
    Attached Images Attached Images
    'Lime Time'
    1975 AristoCraft Nineteen
    Mercruiser 165hp (chevy 250 L6), MC-1 drive

  14. #14
    Admiral ziggy's Avatar
    Join Date
    Jun 2004
    Location
    Lincoln, NE. Branched Oak Lake
    Posts
    7,152

    Default Re: trim won't work, 2011 glastron mx185,(resolved)

    well, turns out there was a vital (imho) piece of info that we didn't have.

    the remote had been removed to service an inop hr meter which is located right next to the remote.
    the trim wire disconnect plug right behind the remote was not reinstalled when the remote was put back after the hr meter repair..

    neighbors getting happier by the min. i think...

    thanks again for the help..

    ps. i made it to the lake yesterday only to get monsooned on for three hrs prior to giving in to the bad weather. now i gotta clean up my disaster after coming home on wet pavement.. wet, soggy, filthy boat now... only thing i'll say good is that it was better than not going boating at all. but not by much..
    'Lime Time'
    1975 AristoCraft Nineteen
    Mercruiser 165hp (chevy 250 L6), MC-1 drive

Similar Threads

  1. glastron gt185 vs mx185
    By 1979checkmate in forum Boat Topics and Questions (not engine topics)
    Replies: 10
    Last Post: May 4th, 2011, 11:20 PM
  2. New 2011 Glastron GT 205 vs salt water....who will win?
    By cptnmcluvin in forum Boat Topics and Questions (not engine topics)
    Replies: 5
    Last Post: February 27th, 2011, 11:50 AM
  3. RPM Gauge does not work Glastron 185
    By petermb72 in forum Electrical, Electronics, Audio and Trolling Motors
    Replies: 3
    Last Post: June 18th, 2008, 12:28 AM
  4. RPM Gauge does not work Glastron 185
    By petermb72 in forum Johnson & Evinrude Outboards
    Replies: 1
    Last Post: June 17th, 2008, 07:45 AM
  5. RPM Gauge does not work Glastron 185
    By petermb72 in forum Boat Topics and Questions (not engine topics)
    Replies: 0
    Last Post: June 17th, 2008, 12:41 AM
  1. iboats Forum Directory - Over 100,000 forum posts organized by topic