Please note this thread has been inactive for 90 days. For the best results, please start a new thread.
Results 1 to 5 of 5
  1. #1
    Seaman Apprentice
    Join Date
    Mar 2009
    Posts
    48

    Default possible overheating problem!

    just bought a 1988 regal sebring W/ a 4 bbl 4.3 L v6. alpha 1 merc. took it to the lake today for the first time. at idle speed, in or out of gear it over heats! temp needle goes above 3/4. as soon as the rpm's are above 2000 it drops to normal. does not over heat at all w/ muffs. is this normal? should i maybe check the thermostat? the impeller was replaced last year. any help would be great. thanks.

  2. #2
    Honorary Moderator Emeritus Don S's Avatar
    Join Date
    Aug 2004
    Location
    Western WA.
    Posts
    62,323

    Default Re: possible overheating problem!

    The raw water pump impeller is the FIRST thing to check on any marine engine overheat. There are so many things that can cause them to fail.
    Don S.


    Please, no PM's (Private Messages) regarding boat/engine problems.
    That is what the forums are for.
    Only forum/moderator issues will be answered in PM's.

  3. #3
    Seaman Apprentice
    Join Date
    Mar 2009
    Posts
    48

    Default Re: possible overheating problem!

    is that the one in the lower unit? or on the motor? sorry, im a rookie

  4. #4
    Honorary Moderator Emeritus Don S's Avatar
    Join Date
    Aug 2004
    Location
    Western WA.
    Posts
    62,323

    Default Re: possible overheating problem!

    Yes, it should be in the outdrive.
    Head up to the Adults Only sticky at the top of this forum, and download the OEM service manual for you engine and drive. #6 manual covers the pump.
    Don S.


    Please, no PM's (Private Messages) regarding boat/engine problems.
    That is what the forums are for.
    Only forum/moderator issues will be answered in PM's.

  5. #5
    Seaman Apprentice
    Join Date
    Mar 2009
    Posts
    48

    Default Re: possible overheating problem!

    thanks again don

Similar Threads

  1. overheating problem?
    By sluketic in forum Mercruiser I/O & Inboard Engines & Outdrives
    Replies: 6
    Last Post: September 6th, 2007, 03:44 PM
  2. overheating problem
    By riptide1947 in forum Johnson & Evinrude Outboards
    Replies: 3
    Last Post: March 31st, 2007, 10:01 AM
  3. Overheating problem
    By RetNav in forum Non-Boating Technical Topics
    Replies: 6
    Last Post: April 20th, 2004, 02:55 AM
  4. Overheating problem?
    By Glock45 in forum Johnson & Evinrude Outboards
    Replies: 6
    Last Post: May 23rd, 2003, 06:13 AM
  5. Overheating Problem
    By NASCARMAN in forum Non-Repair Outboard Discussions
    Replies: 3
    Last Post: October 16th, 2001, 06:35 AM
  1. iboats Forum Directory - Over 100,000 forum posts organized by topic