Please note this thread has been inactive for 90 days. For the best results, please start a new thread.
Results 1 to 7 of 7
  1. #1
    Seaman
    Join Date
    Sep 2007
    Location
    Québec,Canada
    Posts
    72

    Default No Power on Ignition Switch Merc 260 1984

    1984 Mercruiser 260 5.7L S/N 6846787
    I had never had problem before and last week end I tried to start my engine with no luck.
    When I turn the key, nothing happens; No Click on the starter, the guages does not have power doesn't move.
    I checked the Ighition Switch Fuse and it is not blowed. I have no voltage at the Batt Wire on the Ighition Switch.
    My Quick Silver Control is on Neutral Position (knob pressed).
    I need some help with my problem.
    Thanks
    Louis

  2. #2
    Moderator Bondo's Avatar
    Join Date
    Apr 2002
    Location
    The Mouth of the Chaumont River, Ny.
    Posts
    52,607

    Default Re: No Power on Ignition Switch Merc 260 1984

    Quote Originally Posted by HPLou View Post
    1984 Mercruiser 260 5.7L S/N 6846787
    I had never had problem before and last week end I tried to start my engine with no luck.
    When I turn the key, nothing happens; No Click on the starter, the guages does not have power doesn't move.
    I checked the Ighition Switch Fuse and it is not blowed. I have no voltage at the Batt Wire on the Ighition Switch.
    My Quick Silver Control is on Neutral Position (knob pressed).
    I need some help with my problem.
    Thanks
    Louis
    Ayuh,... There's a 50amp breaker On yer motor, that probably needs to be reset...

    'course, then ya gotta find the short that tripped it...
    Any Grease is Better,..... Than No Grease at All.......

  3. #3
    Seaman
    Join Date
    Sep 2007
    Location
    Québec,Canada
    Posts
    72

    Default Re: No Power on Ignition Switch Merc 260 1984

    Thanks Bond'O for your quick reply.
    There is a Red Button on the motor,
    Is it the one youre taking about? (sorry no photos)
    I can not press to reset. Seems to be jammed.
    Louis

  4. #4
    Moderator Bondo's Avatar
    Join Date
    Apr 2002
    Location
    The Mouth of the Chaumont River, Ny.
    Posts
    52,607

    Default Re: No Power on Ignition Switch Merc 260 1984

    Quote Originally Posted by HPLou View Post
    Thanks Bond'O for your quick reply.
    There is a Red Button on the motor,
    Is it the one youre taking about? (sorry no photos)
    I can not press to reset. Seems to be jammed.
    Louis
    Ayuh,... That's it,... Get yer Testlight, 'n follow the Power...

    That's just my 1st Guess,...
    If it don't push in, maybe it ain't the problem... a Testlight will tell ya...
    Any Grease is Better,..... Than No Grease at All.......

  5. #5
    Seaman
    Join Date
    Sep 2007
    Location
    Québec,Canada
    Posts
    72

    Default Re: No Power on Ignition Switch Merc 260 1984

    Thanks Bond-O
    I will get back in aa day or two.

  6. #6
    Honorary Moderator Emeritus Don S's Avatar
    Join Date
    Aug 2004
    Location
    Western WA.
    Posts
    62,323

    Default Re: No Power on Ignition Switch Merc 260 1984

    When you test the circuit breaker with the test light or a volt meter, make sure you check both terminals. It wouldn't be the first breaker to fail for no reason in the marine environment on a hot engine that probably gets wet with condensation.
    Might also check to see if you have a 15 or 20A fuse under the dash near the ignition switch in the red/purple wire.
    Don S.


    Please, no PM's (Private Messages) regarding boat/engine problems.
    That is what the forums are for.
    Only forum/moderator issues will be answered in PM's.

  7. #7
    Seaman
    Join Date
    Sep 2007
    Location
    Québec,Canada
    Posts
    72

    Default Re: No Power on Ignition Switch Merc 260 1984

    I checked the 20A fuse under the dash near the ignition switch and it's OK
    The connector from the 12V panel that supplies electricity to the fuse was defective.
    I replaced it and all is working now.
    Thank You All for your help.

Similar Threads

  1. Coil, Stator, Power Pack, Ignition Switch, Kill Switch?
    By rlowhorn in forum Johnson & Evinrude Outboards
    Replies: 4
    Last Post: April 5th, 2012, 01:26 PM
  2. Merc 150 losing power after new ignition switch?
    By bebeard in forum Mercury & Mariner Outboards
    Replies: 10
    Last Post: October 3rd, 2007, 12:35 PM
  3. 1984 60 hp ignition switch
    By bdirect in forum Mercury & Mariner Outboards
    Replies: 1
    Last Post: October 2nd, 2004, 11:20 AM
  4. 1984 60 hp ignition switch
    By bdirect in forum Mercury & Mariner Outboards
    Replies: 0
    Last Post: September 30th, 2004, 08:38 PM
  5. 1984 115hp v-4 ignition switch
    By Penn Pal in forum Johnson & Evinrude Outboards
    Replies: 3
    Last Post: July 23rd, 2003, 03:29 PM
  1. iboats Forum Directory - Over 100,000 forum posts organized by topic