Please note this thread has been inactive for 90 days. For the best results, please start a new thread.
Results 1 to 7 of 7
  1. #1

    Default Mercruiser 888 Tilt / Trim Issues

    Symptoms: In neutral, forward or reverse (engine off, on trailer, etc) I can grab the skeg and lift the outdrive up by hand with very little hydraulic resistance. I can then lower it back to the original position by letting it down (again, by hand).

    On the water, I can put it in reverse and it creeps up - it doesn't pop up. Of course, I didn't rev it up to see if it would pop up.

    In forward, it creeps towards full trimmed down position (slowly). I have to tap the trim up switch from time to time to keep the bow from digging in as I cruise.

    History: Previous owner had replaced all exterior trim hoses. I have not checked for water in tilt / trim fluid. I don't have gauges set up to perform tests of the hydraulics as denoted in the Mercruiser manual.

    My question to those experienced is this: Should I start by tearing down the cylinders? I suspect bad or rust covered check balls and springs in the cylinder piston assy. The cylinder ends have marks suggesting that they have been disassembled before.

    I'm okay with working on hydraulic systems, but I'm not familiar with the construction of tilt / trim cylinders.

    Guidance and help is appreciated.

  2. #2
    Petty Officer 1st Class ken_23434's Avatar
    Join Date
    Jul 2008
    Location
    Hampton Roads, VA
    Posts
    313

    Default Re: Mercruiser 888 Tilt / Trim Issues

    Do you have the service manual for the drive? It's available in the Adults only Sticky.

    I haven't done it, but I would bet the procedure is in the service manual.
    20' Suntracker Pontoon

  3. #3
    Petty Officer 2nd Class
    Join Date
    May 2009
    Location
    Long Beach, WA
    Posts
    150

    Default Re: Mercruiser 888 Tilt / Trim Issues

    Surfdancer, It sounds like who ever changed out the hoses didn't refill or bleed the system correctly. Refill the tank (unit down) with ATF and operate your trim several times to remove air. Look for ATF leaks while you operate them. Unless you struck something it's not likely you need to rebuild rams. The rams/cylinders are simple to rebuild once you get them apart. THAT'S the hard part. Don't put your rams into a vise... smashing the tubes will ruin them.

  4. #4

    Default Re: Mercruiser 888 Tilt / Trim Issues

    Quote Originally Posted by "G" View Post
    Surfdancer, It sounds like who ever changed out the hoses didn't refill or bleed the system correctly. Refill the tank (unit down) with ATF and operate your trim several times to remove air. Look for ATF leaks while you operate them. Unless you struck something it's not likely you need to rebuild rams. The rams/cylinders are simple to rebuild once you get them apart. THAT'S the hard part. Don't put your rams into a vise... smashing the tubes will ruin them.
    I'll give that a try...

    Thanks!

  5. #5
    Cadet
    Join Date
    Jul 2011
    Location
    Anoka
    Posts
    6

    Default Re: Mercruiser 888 Tilt / Trim Issues

    Quote Originally Posted by Surfdancer View Post
    I'll give that a try...

    Thanks!
    I have a 75 888 drive, I just replace the High pressure line from the pump to the diaphraghm and I can get it to trim all the way up but only down half way. I have filled it and checked it every time it was all the way up. Does the bleed process take a long time? Or do I have another issue?

  6. #6
    Cadet
    Join Date
    Jul 2011
    Location
    Anoka
    Posts
    6

    Default Re: Mercruiser 888 Tilt / Trim Issues

    Quote Originally Posted by lurch67 View Post
    I have a 75 888 drive, I just replace the High pressure line from the pump to the diaphraghm and I can get it to trim all the way up but only down half way. I have filled it and checked it every time it was all the way up. Does the bleed process take a long time? Or do I have another issue?
    I saw there is a Service manual out there can someone please repost that link??!!

  7. #7
    Honorary Moderator Emeritus Don S's Avatar
    Join Date
    Aug 2004
    Location
    Western WA.
    Posts
    62,323

    Default Re: Mercruiser 888 Tilt / Trim Issues

    Welcome to iboats lurch, you need to start a new thread of your own with your questions and not dig up 4 year old threads out of the archives.
    Don S.


    Please, no PM's (Private Messages) regarding boat/engine problems.
    That is what the forums are for.
    Only forum/moderator issues will be answered in PM's.

Similar Threads

  1. Mercruiser 888-1/0 1978-tilt & trim pump
    By mozie-1 in forum Mercruiser I/O & Inboard Engines & Outdrives
    Replies: 2
    Last Post: May 19th, 2008, 06:22 PM
  2. Mercruiser 888 Trim limit switch/sender
    By jhay77 in forum Mercruiser I/O & Inboard Engines & Outdrives
    Replies: 0
    Last Post: May 16th, 2007, 10:11 PM
  3. trim pump on 1972 mercruiser 888
    By ImaDirtyBoater in forum Mercruiser I/O & Inboard Engines & Outdrives
    Replies: 3
    Last Post: October 25th, 2006, 11:36 PM
  4. Need advice on Mercruiser 888 trim problem
    By ChesapeakeJohn in forum Mercruiser I/O & Inboard Engines & Outdrives
    Replies: 7
    Last Post: May 9th, 2006, 04:06 PM
  5. mercruiser 470 tilt/trim issues
    By JasonJ in forum Mercruiser I/O & Inboard Engines & Outdrives
    Replies: 4
    Last Post: July 7th, 2004, 04:52 PM
  1. iboats Forum Directory - Over 100,000 forum posts organized by topic