Please note this thread has been inactive for 90 days. For the best results, please start a new thread.
Results 1 to 4 of 4
  1. #1
    Cadet
    Join Date
    Apr 2011
    Posts
    1

    Default Boat won't start, just clicks

    I've had the boat winterized and it sat in the garage for the winter. I've never used this boat, because I bought it very late in the Fall. I charged the battery and put the two wire connectors on the + and _ poles. The two ground wires are tapped on the large battery poles. I turn the key and all I get is "clicking".

  2. #2
    Lieutenant Junior Grade 90stingray's Avatar
    Join Date
    Oct 2010
    Location
    Kansas
    Posts
    1,139

    Default Re: Boat won't start, just clicks

    Make sure motor is not locked up by turning over manually. I would also pull the starter and have it tested... they do get corroded. If you are taking the starter in to be checked you can have the battery tested too. Check the battery cables at the battery, and the starter. Both positive and negative leads. Good place to start.
    Toy - 2001 Glastron GX185, 4.3 Alpha One
    Tow rig - 2013 Silverado 2500HD Duramax

  3. #3
    Moderator Bondo's Avatar
    Join Date
    Apr 2002
    Location
    The Mouth of the Chaumont River, Ny.
    Posts
    52,750

    Default Re: Boat won't start, just clicks

    Quote Originally Posted by DaveRR View Post
    I've had the boat winterized and it sat in the garage for the winter. I've never used this boat, because I bought it very late in the Fall. I charged the battery and put the two wire connectors on the + and _ poles. The two ground wires are tapped on the large battery poles. I turn the key and all I get is "clicking".
    Ayuh,... It's probably corroded wiring connections,...
    They're ALL suspect, both positives, 'n Grounds..
    Remove, sand, clean to Shiney metal, reinstall, 'n grease 'em to stop the corrosion...

    If cleaning the wiring connections don't fix it,...
    Load test the battery...
    Any Grease is Better,..... Than No Grease at All.......

Similar Threads

  1. Clicks when trying to start
    By centextom in forum Mercruiser I/O & Inboard Engines & Outdrives
    Replies: 30
    Last Post: August 29th, 2010, 03:02 PM
  2. Engine clicks but it does not start
    By Moe12345 in forum Mercruiser I/O & Inboard Engines & Outdrives
    Replies: 8
    Last Post: August 7th, 2010, 01:18 PM
  3. Won't start, just clicks..
    By mark1905 in forum Mercruiser I/O & Inboard Engines & Outdrives
    Replies: 11
    Last Post: July 20th, 2008, 06:56 PM
  4. Motor just clicks when trying to start?? HELP
    By bsh21wash in forum Mercury & Mariner Outboards
    Replies: 13
    Last Post: June 26th, 2006, 06:29 AM
  5. boat only clicks when trying to start
    By andrew naeger in forum Non-Repair Outboard Discussions
    Replies: 1
    Last Post: May 25th, 2001, 03:33 AM
  1. iboats Forum Directory - Over 100,000 forum posts organized by topic