Please note this thread has been inactive for 90 days. For the best results, please start a new thread.
Results 1 to 3 of 3
  1. #1
    Cadet
    Join Date
    Feb 2009
    Posts
    17

    Default 4.3L water pump leaking

    My 2000 4.3L is leaking water from the little hole on the top of the water circulating pump on the engine. It is not overheating and is a small amount of water but I believe this is a sign it needs replaced. Is this correct?

    Thanks, Jim

  2. #2
    Petty Officer 1st Class
    Join Date
    Apr 2009
    Posts
    259

    Default Re: 4.3L water pump leaking

    Yes it is there to show you that the seals are bad and needs replaced.

  3. #3
    Lieutenant Junior Grade danond's Avatar
    Join Date
    Jun 2007
    Location
    Bismarck, ND
    Posts
    1,117

    Default Re: 4.3L water pump leaking

    Yep, that's the weep hole. Indicator that it's going bad. Mine did that during first startup this year, but quit once the bushing got warm/lubed by the water. I think I have a season or two left and it'll be ready for replacement, too.
    1989 Starcraft 171S Select "Cap'n Crunch" / OMC Cobra 4.3 V6 / 432APRMED

    If you're going to keep that OMC Cobra, please for the love of everything good in the world, get an OMC factory service manual. Not a Clymers, Not a SELOC. You can find them on eBay.

    My boat repair website: http://transomfix.dcpolk.com


Similar Threads

  1. leaking water pump
    By chadruth in forum Mercruiser I/O & Inboard Engines & Outdrives
    Replies: 3
    Last Post: January 2nd, 2008, 07:59 PM
  2. Leaking water from shifter cable hose OMC Cobra 2.3L 87
    By Baylinercapri1987 in forum OMC I/O & Inboard Engines & Outdrives
    Replies: 18
    Last Post: December 10th, 2006, 04:55 AM
  3. 4.3L Mercruiser leaking hot water into bilge
    By lushka16 in forum Mercruiser I/O & Inboard Engines & Outdrives
    Replies: 13
    Last Post: April 14th, 2006, 05:39 PM
  4. Antifreeze leaking from water pump
    By harrisg in forum Mercruiser I/O & Inboard Engines & Outdrives
    Replies: 7
    Last Post: November 10th, 2005, 03:53 PM
  5. leaking after water pump change
    By Greg22 in forum Johnson & Evinrude Outboards
    Replies: 14
    Last Post: July 12th, 2003, 07:16 AM
  1. iboats Forum Directory - Over 100,000 forum posts organized by topic