Please note this thread has been inactive for 90 days. For the best results, please start a new thread.
Results 1 to 7 of 7
  1. #1
    Cadet ableberry's Avatar
    Join Date
    Dec 2007
    Location
    AK
    Posts
    23

    Unhappy Impeller problems

    Good afternoon,

    I'm replacing my water pump impeller ('77 35 hp) and am having trouble matching impeller to housing. The number on the housing is 323941, which I cannot find anywhere in BRP. BRP has the impeller #319578, but the impeller is too large for the housing I have that came with the kit I changed last winter. (That impeller failed when I took the boat out.) I saw another post that adressed the same thing, and someone mentioned there were three impellers, one of which 18-5031, looks like the one that came with the kit. However, that original OEM number is to a differerent model altogether.

    Could it be that the shop I got the kit from in the first place sold me a kit for the wrong model in the first place?

    -Wes
    Last edited by ableberry; July 29th, 2008 at 12:34 AM. Reason: clarification

  2. #2
    Commander
    Join Date
    Jan 2004
    Location
    Poulsbo, WA
    Posts
    2,265

    Default Re: Impeller problems

    What is your model # and have you verified via the BRP site that your motor is model year 1977?

    BRP shows part no. 0322260 ($52.11) for pump housing, 0775521 ($19.95) for impeller and 0389980 ($55.99) for water pump kit. The Sierra Marine # for the impeller is 18-3006. Note the superseded # on the impeller is 0378891.

    Maybe you should compare the parts you have with one or all of the above. The dlr is bound to have some of them in stock, I'd think.

    BTW you can't always relate a part # stamped on an OMC part to a "real" part #, for some reason some stuff has a number that'll show up in the system and some don't. Not sure wazzup wid that, but I've had good luck with the parts locater at Crowley Marine's site, it always seems to pull up the current # for anything you put in that used to be a good #. Your #323941 doesn't come up there, either.

    http://www.crowleymarine.com/omc_mercury_parts.cfm

    Note on the impeller being too large for the housing, does that mean it was too thick to fit, or the blades won't 'screw' into the housing. Remember that the blades have to 'curl' into the housing and that's considerably less diameter than when the blades are free-standing, out straight.

    HTH & maybe this'll help lead you to the right parts for your motor......ed

  3. #3
    Cadet ableberry's Avatar
    Join Date
    Dec 2007
    Location
    AK
    Posts
    23

    Default Re: Impeller problems

    All those part #s jive with what BRP says for the model number and year of my engine. (both are from the ID plate on the motor.)

    The impeller look like it would fit vertically, but is too wide for the housing. The impeller is 2.75 in across, while the housing is 1.75. Does this seem liek too much curl when placed in the housing? I would think it would wear out over time. The impeller that came with the kitseemed to fit straight in without curling the blades.


    -Thanks for the help

    -Wes

  4. #4
    Honorary Moderator Emeritus tashasdaddy's Avatar
    Join Date
    Nov 2005
    Location
    Jacksonville, Florida
    Posts
    51,017

    Default Re: Impeller problems

    the vanes are suppose to curl. the shaft in the water pump is off centered. so the vanes move when operating.
    FLORIDA GATORS
    TEBOW Country



    Please, NO PM's (Private Messages) regarding boat/engine problems. they will not be answered.
    That is what these forums are for. Post your questions, in the appropriate Forum.

  5. #5
    Cadet ableberry's Avatar
    Join Date
    Dec 2007
    Location
    AK
    Posts
    23

    Default Re: Impeller problems

    Alright, this time I have pictures... see attached

    The water pump repair kit for a '77 35hp Johnson, BRP part #0389980. This is the kit referenced from the BRP site off the engine diagram.

    Note the impeller for the same engine, same source for parts (BRP Web Site).

    There is a distinct difference between the impeller that comes with the kit and the one listed as the replacement. There is also an apparent physical difference in the housing displayed on the BRP engine diagram than that supplied in the kit.

    Is it still advised to try to fit the large impeller in this kit?

    -Wes
    Attached Images Attached Images

  6. #6
    Honorary Moderator Emeritus tashasdaddy's Avatar
    Join Date
    Nov 2005
    Location
    Jacksonville, Florida
    Posts
    51,017

    Default Re: Impeller problems

    what is the model # on your motor?
    FLORIDA GATORS
    TEBOW Country



    Please, NO PM's (Private Messages) regarding boat/engine problems. they will not be answered.
    That is what these forums are for. Post your questions, in the appropriate Forum.

  7. #7
    Cadet ableberry's Avatar
    Join Date
    Dec 2007
    Location
    AK
    Posts
    23

    Default Re: Impeller problems

    Model number is - 35RL77H

Similar Threads

  1. Impeller Problems???
    By Deimos357 in forum Mercruiser I/O & Inboard Engines & Outdrives
    Replies: 1
    Last Post: May 26th, 2008, 05:00 PM
  2. Impeller problems!!!!!!!!!!!
    By Snookkrook in forum Mercury & Mariner Outboards
    Replies: 2
    Last Post: February 10th, 2008, 11:06 AM
  3. impeller problems
    By dbess7 in forum Mercury & Mariner Outboards
    Replies: 4
    Last Post: September 12th, 2007, 01:22 AM
  4. Impeller problems
    By breton26 in forum Johnson & Evinrude Outboards
    Replies: 1
    Last Post: June 26th, 2005, 12:47 PM
  5. Impeller problems
    By Wizard30 in forum Yamaha & Suzuki Outboards
    Replies: 3
    Last Post: September 3rd, 2004, 02:49 AM
  1. iboats Forum Directory - Over 100,000 forum posts organized by topic