Please note this thread has been inactive for 90 days. For the best results, please start a new thread.
Results 1 to 8 of 8
  1. #1

    Default Help with a NO OIL LIGHT on a 2000 Evinrude Ficht 150

    Hi there...
    Ive exhausted all of my back yard "know how" and I cant bear to bring my motor to the stealer oops, I mean the Dealer to solve my "NO OIL LIGHT" that comes on problem...I hope someone here can help!
    I have a 2000, Evinrude FICHT 150Hp with about 600 hours on it. While out this past weekend and after some high speed running and a few miles of trolling out at Cape Cod, we were on our way into Pamet harbor when the "No oil light" suddenly came on with that ear piercing tone....Anyway, I have plenty of RAM oil in the tank (2gals) and the primer bulb was hard. We shut the motor down and restarted. The light and tone were gone and things appeared back to normal. I figured that this was a fluke so I went back out into the bay, buzzed around at high and low speeds and decided it was "fixed". Again, back into port (while going about 3knts) and the light and tone came back. I shut the motor off, turned it back on again and the light and tone were now off. We put the it on the trailer and called it a bad day.
    Next day, at the lake, the light and noise came on about 2 times only while at very slow speeds.
    HERES WHAT I HAVE DONE SO FAR:
    I cleaned and inspected the oil pressure switch..looks fine, clean and no corrosion. (oh, also I have already ordered a new one for only 23$ I figure I should start there)
    I have verified that the return oil line to the reservoir was flowing at an adequate rate of flow while the motor was at 1500rpm say 12oz or so per min.
    I have removed and verified that all of the oil lines on the oil distribution manifold (just above the electric oil pump that looks like a fuel injector pump) are squirting oil at an adequate level as well.
    I have tested oil pressure by screwing a mechanical oil pressure tester into the same hole that the oil pressure sender switch occupies. I found this motor to have CONSISTENT 12psi when at startup, idle and out to about 2800rpms. It goes up a bit after 2800 but I dont want to run this motor WOT on a garden hose...lol.
    Heres what the local stealers have told me: "needs an oil pump" "needs an oil pump diaphram" "you need a new tachometer" "needs an oil pressure sending switch" "aw, thats just a FICHT being a FICHT" on and on and on...
    Should any of you have a suggestions PLEASE let me know and that would be most appreciated!!!!!!!!!

  2. #2
    Chief Petty Officer
    Join Date
    Jul 2007
    Location
    Owensboro, KY
    Posts
    459

    Default Re: Help with a NO OIL LIGHT on a 2000 Evinrude Ficht 150

    Was it a constant tone or variable chirp? I've heard about instances where the engine sends out the wrong signal, but the warning sensor picks it up right. For instance your check oil light might be on, but if it's a constant tone like a fire alarm then you have a fuel related or overheating issue. Boat builders make common wiring mistakes all of the time.

    For instance, my 95 Skeeter 200SL had an issue with the warning horn going off when I would turn on the aerator! Come to find out some Nit Wit at the factory wired the aerator pump to the Nav light switch on the boat, and everytime I would turn on the aerator it would overload the switch and cause a short. After talking to a few Skeeter owners over the net I found out it was a problem with several boats produced within a 2 month period of each other. It was just some idiot at the factory that didn't pay attention. If you could describe the tone in more detail it would be great!

  3. #3
    Senior Chief Petty Officer
    Join Date
    Mar 2005
    Location
    Wollongong Australia
    Posts
    761

    Default Re: Help with a NO OIL LIGHT on a 2000 Evinrude Ficht 150

    more than likely it is the "no oil sensor" pretty common to have an intermittant fault with them, I have seen a few now, very easy to replace to test it, and not very expensive, but if in doubt take it to your local stealer!

  4. #4

    Exclamation Re: Help with a NO OIL LIGHT on a 2000 Evinrude Ficht 150

    Thanks...both equally good suggestions.
    I have ordered and plan on replacing the oil pressure sensor (sender) switch. Its going to be here on Thursday and cost just about 25$. It was the least expensive part in this entire oil assembly.
    As for the tone and light, the tone was a constant BEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE EEEEEEEEEP that would not cease until I put the key into the run position; the red no oil light was constantly illuminated and also would not go away until I shut the motor down. I have been plagued by many broken water pumps on this motor and know exactly what the computer, lights, noises and motors responses are to an overheat condition.
    Trust me, this new "no oil" light situation is much different.
    I got my hands on a shop repair manual last night and it stated that this sensor is set at 4psi and wont send a signal until the oil psi stays below 4psi for quite some time. With that mechanical gauge reading I took yesterday, Im still bettting on the sensor and PRAYING its not the oil injector pump at a mere $660.00

  5. #5
    Chief Petty Officer
    Join Date
    Jul 2007
    Location
    Owensboro, KY
    Posts
    459

    Default Re: Help with a NO OIL LIGHT on a 2000 Evinrude Ficht 150

    I seriously doubt it has anything to do with your oil.

    I had the Exact same thing happen to me in the situation described above. /\ /\ /\

    Actually that tone is a Fuel restriction warning or overheat warning depending on the circumstances. Here are the instances where you hear a horn, and the descriptions.

    Overheat = Continuous tone similar to a fire alarm in your home.

    No Oil = continuous short tones

    Low Oil = chirp every 40 seconds

    Fuel restriction = Continuous tone at or near full throttle.

    I would check out all of the possibilities, and then start testing switches. Chances are you have an electrical problem. It's easy to throw money at a problem that seems evident, but when you get to the end of it nothing has been fixed. It's funny they don't mention "electrical issues" in our manuals as they account for 50% of us replacing parts in error.

  6. #6
    Rear Admiral
    Join Date
    Jan 2002
    Posts
    4,681

    Default Re: Help with a NO OIL LIGHT on a 2000 Evinrude Ficht 150

    Quote Originally Posted by luckyinkentucky View Post

    Overheat = Continuous tone similar to a fire alarm in your home.

    No Oil = continuous short tones

    Low Oil = chirp every 40 seconds

    Fuel restriction = Continuous tone at or near full throttle.

    luckyinkentucky,

    What you posted does NOT apply to motors 1996 and later!

  7. #7

    Thumbs down Re: Help with a NO OIL LIGHT on a 2000 Evinrude Ficht 150

    Well....
    Since people seem to think that my motor is overheating let me start by saying I have a brand new Evinrude water pump impeller housing and "entire top half" of the pump installed. This pump is approximately 1 month old and has about 25 hours on it. This pump is changed every year by myself. The tell tale water squirt is exceptional and is perfect for this season. I have owned this motor for 7 years, installed 7 water pumps and know when ones on the way out or when its already broken (no tell tale, poor tell tale, hot light on tach comes on with the incessant beep etc). With that being said, lets agree that this is NOT a cooling issue at this time. If it were, the motor would be warmer then usual, the motor would have gone into S.L.O.W. mode and the tell tale would be squirting warm water which it is not. Also, I would not be able to do high speed runs (and have no light come on). As it seems that the NO OIL light and tone only come on at slow, (under 5knts) operation.

  8. #8

    Default Re: Help with a NO OIL LIGHT on a 2000 Evinrude Ficht 150

    Quote Originally Posted by boatyug View Post
    Well....
    Since people seem to think that my motor is overheating let me start by saying I have a brand new Evinrude water pump impeller housing and "entire top half" of the pump installed. This pump is approximately 1 month old and has about 25 hours on it. This pump is changed every year by myself. The tell tale water squirt is exceptional and is perfect for this season. I have owned this motor for 7 years, installed 7 water pumps and know when ones on the way out or when its already broken (no tell tale, poor tell tale, hot light on tach comes on with the incessant beep etc). With that being said, lets agree that this is NOT a cooling issue at this time. If it were, the motor would be warmer then usual, the motor would have gone into S.L.O.W. mode and the tell tale would be squirting warm water which it is not. Also, I would not be able to do high speed runs (and have no light come on). As it seems that the NO OIL light and tone only come on at slow, (under 5knts) operation.
    any more thoughts?

Similar Threads

  1. Year 2000 225 Evinrude Ficht No Oil light
    By doug brander in forum Johnson & Evinrude Outboards
    Replies: 5
    Last Post: January 16th, 2012, 08:59 AM
  2. 2000 175 Evinrude FICHT
    By MokieB in forum Johnson & Evinrude Outboards
    Replies: 7
    Last Post: April 15th, 2010, 04:31 PM
  3. 2000 Evinrude 225 Ficht
    By kelly holmes in forum Johnson & Evinrude Outboards
    Replies: 3
    Last Post: May 23rd, 2006, 06:33 PM
  4. 2000 225hp evinrude ficht fuel starvation? no ck eng light
    By slcstein@comcast.net in forum Johnson & Evinrude Outboards
    Replies: 11
    Last Post: February 25th, 2006, 02:04 AM
  5. 2000 Evinrude 175 ficht
    By boatfever in forum Johnson & Evinrude Outboards
    Replies: 3
    Last Post: August 2nd, 2005, 09:30 AM
  1. iboats Forum Directory - Over 100,000 forum posts organized by topic