Please note this thread has been inactive for 90 days. For the best results, please start a new thread.
Results 1 to 7 of 7
  1. #1

    Default 70 hp evinrude slows down after running full throttle

    my 1979 70 hp evinrude starts and idles great,takes off and runs fine for a little bit then slows down and starts to surge.let it idle a bit then it will go again for a short while.i've changed fuel tanks,lines checked for leaks,changed plugs.i changed batteries when it was doing it then it ran great for a longer time the it slowly started doing it again.the battery will still start the motor.thanks for any help

  2. #2
    Admiral
    Join Date
    Aug 2002
    Location
    corpus christi texas
    Posts
    6,873

    Default Re: 70 hp evinrude slows down after running full throttle

    Insure that your fuel tank is venting properly and engine is not overheating.If waterpump and thermostat haven't been replaced in a few years it's due.Next time you water test it try pumping the primer bulb and see if engine picks up.If so,the fuel pump may be worn out.

  3. #3

    Default Re: 70 hp evinrude slows down after running full throttle

    i check all of that and it still does it. the only thing that seemed to help was changing batteries. then after awhile it does it again

  4. #4
    Admiral
    Join Date
    Aug 2002
    Location
    corpus christi texas
    Posts
    6,873

    Default Re: 70 hp evinrude slows down after running full throttle

    You may have a problem with the charging system of your engine.Not sure if that year model uses a capacitance discharge power pack ,but if it does it requires a battery of at least 70 amp hour rating.With engine off and then running test voltage accross the battery terminals and see if the voltage increases to around 13 volts when engine is running.Perhaps Joe Reeves will show up shortly and help shine some light on this subject.Meanwhile,try posting the model number of engine so that we can be certain of the year.

  5. #5

    Default Re: 70 hp evinrude slows down after running full throttle

    it does have the cd3 system.motor is a model#70973R ser.#J0002516 i checked the rectifier per my clymer manual, it seems to be bad. could that cause my problem? i'm getting a new one tomorrow.

  6. #6

    Default Re: 70 hp evinrude slows down after running full throttle

    still needing help

  7. #7

    Default Re: 70 hp evinrude slows down after running full throttle

    new rectifier fixed it. thanks for the help

Similar Threads

  1. 1977 mercury 500 50 hp not running full speed at full throttle.
    By LeeHicks23 in forum Mercury & Mariner Outboards
    Replies: 3
    Last Post: August 12th, 2009, 06:18 PM
  2. 80's 60hp Evenrude slows near full throttle
    By phillips407 in forum Johnson & Evinrude Outboards
    Replies: 4
    Last Post: March 14th, 2008, 08:31 PM
  3. Evinrude slows down after running for a few minutes
    By Eddie Polite in forum Johnson & Evinrude Outboards
    Replies: 9
    Last Post: August 18th, 2005, 03:40 PM
  4. 15 H.P. Evinrude, speeds up and slows down at full throttle
    By rifflerunner in forum Johnson & Evinrude Outboards
    Replies: 4
    Last Post: April 2nd, 2005, 03:51 AM
  5. 6HP Evinrude 1979 slows down at full throttle in gear, idles fine
    By LookaSnooka in forum Johnson & Evinrude Outboards
    Replies: 2
    Last Post: March 18th, 2005, 06:22 AM
  1. iboats Forum Directory - Over 100,000 forum posts organized by topic