Please note this thread has been inactive for 90 days. For the best results, please start a new thread.
Results 1 to 7 of 7
  1. #1

    Question 1988 Evinrude 90 HP runs but no power

    The engine starts and idles OK, but has very little power. I do not have a working tachometer but am guessing it will only turn about 1500 RPM under load at WOT. It will rev up quite high when out of gear when using the fast idle lever, but it has to warm up a bit before it will rev up even then. Any help you can give me?

  2. #2
    Commander bifflefan's Avatar
    Join Date
    May 2009
    Location
    Grand Rapids, Michigan
    Posts
    2,874

    Default Re: 1988 Evinrude 90 HP runs but no power

    sound like your missing a couple cylinders.

    do spark and compression tests.
    thsi should tell the tale.
    2011 Triton 190 Escape SE 150 Mercury Pro XS

    I never learned much from winning, but always learn from failure.
    Semper Fi

  3. #3
    Vice Admiral bktheking's Avatar
    Join Date
    Jul 2008
    Location
    Carleton Place, Ontario
    Posts
    5,048

    Default Re: 1988 Evinrude 90 HP runs but no power

    She's only firing on 2, they rev up great in neutral but put em on the lake and it's like an elephant is in the boat. Connect it to muffs, run it for a while and put your hand on the cylinder head, the cold one has no fire.

  4. #4
    Fleet Admiral
    Join Date
    Dec 2005
    Location
    LaGrange, Illinois
    Posts
    8,393

    Default Re: 1988 Evinrude 90 HP runs but no power

    Start by checking to see if you have good spark to all 4 plug wires. When the engine is warmed up, put an inductive timing light on each wire. This should show plug misfires or nofires. Or- when running, you can pull the plug wire off each spark plug. As you do that, listen to the engine. If you pull a wire off and the engine does not slow down at all, that wire/plug is probably not firing.

  5. #5
    Honorary Moderator Emeritus tashasdaddy's Avatar
    Join Date
    Nov 2005
    Location
    Jacksonville, Florida
    Posts
    51,017

    Default Re: 1988 Evinrude 90 HP runs but no power

    FLORIDA GATORS
    TEBOW Country



    Please, NO PM's (Private Messages) regarding boat/engine problems. they will not be answered.
    That is what these forums are for. Post your questions, in the appropriate Forum.

  6. #6
    Cadet
    Join Date
    Feb 2012
    Location
    Baton Rouge, La
    Posts
    1

    Default Re: 1988 Evinrude 90 HP runs but no power

    I had an '82 Johnson 90hp that would cut in and out at any throttle above idle. The machanic replaced the stator coil and one power pack. I was told that even with good compression, perfect timing, and even the appearance of spark when grounding a plug; the stator and power pack sometimes will not produce enough power to reach max rpm. It is possible to measure the stator and power pack output to verify proper levels. Hope this helps.

  7. #7
    Chief Petty Officer
    Join Date
    Sep 2009
    Location
    Florabama
    Posts
    612

    Default Re: 1988 Evinrude 90 HP runs but no power

    +1 cylinder drop. More than likely it's a spark issue but if you do find you have spark on all 4 (seriously doubt it) then premix some fuel/oil in a spray bottle and spray it down the carb throats and see what happens.

    To find out what's going on here you will need a spark tester, cheap at any auto store, and a compression tester, cheap from places like Harbor Freight or eBay but expensive at auto stores. Follow the spark and compression testing instructions in the Top Secret file at the top of this section of the forum.

    Post results.

Similar Threads

  1. 65hp Evinrude runs rough and no power
    By areis34 in forum Johnson & Evinrude Outboards
    Replies: 7
    Last Post: August 21st, 2009, 12:59 AM
  2. 1978 Evinrude 9.9- Runs but no power?
    By aberger in forum Johnson & Evinrude Outboards
    Replies: 1
    Last Post: June 16th, 2007, 11:09 PM
  3. 1988 evinrude 120hp fires and runs 1min then turns off
    By jgarcia in forum Johnson & Evinrude Outboards
    Replies: 2
    Last Post: June 13th, 2007, 04:09 PM
  4. 77 evinrude runs at half power
    By DanFranks in forum Johnson & Evinrude Outboards
    Replies: 7
    Last Post: January 1st, 2004, 07:06 PM
  5. 1988 Force 15HP Loss of Power - Runs ok in the tank
    By karvin in forum Force & Chrysler Outboards
    Replies: 2
    Last Post: September 18th, 2002, 12:46 PM
  1. iboats Forum Directory - Over 100,000 forum posts organized by topic