Welcome Guest - Sign Up today
Welcome Guest - Sign Up today
Store Links Mobile - Shop Now

Announcement

Collapse
No announcement yet.

1989 barretta 185 success overheats at WOT and will not accelerate

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1989 barretta 185 success overheats at WOT and will not accelerate

    Ok so I purchased this boat and was told it ran fine, I do have experience with boats but never a Volvo/Penta combo this one is equipped with the (AQ131D/ 290 outdrive) I took it out and put it in the river for a test run and it seemed to run fine until it stopped running period so I floated it back to the dock found a faulty fuel line was the issue and replaced it problem solved so I thought. But this was just the beginning, so I took it out for the second time and it immediately starts to overheat 30 yards from the dock I brought it back in and checked the fluid in the heat exchanger (what didn't overflow) and noticed the water strainer was bone dry. SO I pulled the impeller cover and Walla the impeller had grenaded so I ran over to the marina and grabbed a new one threw it in and took off again well made it about the same distance smh. took it back home yanked everything looking for impellor pieces the mainifold,heat exchanger,waterpump,thermostat,and hose inlet on the outdrive could not find any placed all seals and new thermostat and water pump for good measure, so I finally got it to start pulling water through the outdrive again and I take it out to the lake this weekend and at idle up to 2500 RPM no overheating will run all day but as soon as you put the throttle down it would steadily climb to max temp put would get up and plane out then about an hour or so of riding it stopped accelerating all together had to get back to the dock at about 10 knots with the throttle pegged I'm at a total loss still has stock prop and bone stock set up only modification is electric points ,new plugs ,wires, coil, hoses, seals and oil I'm scratching my head here don't know what else to do PLEASE Help

  • #2
    10 knots with the throttle pegged
    Howdy

    Are you saying your motor is reving high but the boat is only going 10 knots, or your throttle is all the way forward but the motor is barely above idle?
    94 Formula 27PC Custom 509MPI MEFI3 , B3 XR
    95 Rinker 232 w/ 7.4L Carb 0F425011 B1 0F486471
    07 SeaDoo GTX
    Raw Water Pump Maintenance
    Merc Adults Only

    Comment


    • #3
      Rpms will not go above 3k with lever at full throttle struggles to get even 10 knots idles fine and stays at 180 degrees as soon as you hammer down nothing happens and it hits only 3k rpm tops out at 10 knots will not plane

      Comment


      • #4
        And runs hot! As soon as you go back to idle it cools right back down

        Comment


        • #5
          I'm thinking two things, first sounds like you spun your prop hub. Pull the prop off and look and the rubber section around the center of the prop. Second, when was the impeller changed last?
          94 Formula 27PC Custom 509MPI MEFI3 , B3 XR
          95 Rinker 232 w/ 7.4L Carb 0F425011 B1 0F486471
          07 SeaDoo GTX
          Raw Water Pump Maintenance
          Merc Adults Only

          Comment


          • #6
            Impeller was replaced two weeks ago

            Comment


            • #7
              And the prop is fine just pulled it off and checked it I also pulled the heat exhange and all copper pipes and flushed everything

              Comment


              • #8
                The prop is a Michigan wheel 082002-1 14 in rh turn 3 blade

                Comment


                • #9
                  I didn't mention the engine coupler because you didn't mention anything about smelling burnt rubber, but since the prop hub is OK that would be my next check.

                  Can you put the boat in gear and turn the prop on the drive?
                  94 Formula 27PC Custom 509MPI MEFI3 , B3 XR
                  95 Rinker 232 w/ 7.4L Carb 0F425011 B1 0F486471
                  07 SeaDoo GTX
                  Raw Water Pump Maintenance
                  Merc Adults Only

                  Comment


                  • #10
                    Yes prop drives fine just pulled the bottom of the lower unit as well to see if my pick up tube was clogged but it's fine as well

                    Comment


                    • #11
                      Things don't add up. Its in gear and you cannot turn the prop, which is what should happen. Prop is in good shape, prop hub not stripped nor is the coupler, motor turns more then 3K rpms and only get 10 knots.

                      Something is slipping but everything works fine, I have no clue what's wrong. I have to bow out, its over my head
                      94 Formula 27PC Custom 509MPI MEFI3 , B3 XR
                      95 Rinker 232 w/ 7.4L Carb 0F425011 B1 0F486471
                      07 SeaDoo GTX
                      Raw Water Pump Maintenance
                      Merc Adults Only

                      Comment


                      • #12
                        No boat will NOT go over 3k rpm WOT and over heats

                        Comment


                        • #13
                          But does not overheat at idle

                          Comment


                          • #14
                            At 1500 rpm you should be doing at least 10kts, at 2500 you should be moving at least 25kts, your only moving 10kts at the higher rpm as I understand. If this is true something is slipping. Or did I misunderstand?
                            94 Formula 27PC Custom 509MPI MEFI3 , B3 XR
                            95 Rinker 232 w/ 7.4L Carb 0F425011 B1 0F486471
                            07 SeaDoo GTX
                            Raw Water Pump Maintenance
                            Merc Adults Only

                            Comment


                            • #15
                              Sign up today
                              Nothing slipping and 10 knots was an estimate BLUF boat idles fine and will stay at steady 180 degrees at 1000 rpm you can advance the throttle all the to full and nothing happens it seems restricted like it's tied to the dock or you are dragging a huge weight and it steadily moves up in temp to 250 ad soon as you kick It back to idle the temp comes right back down

                              Comment

                              Working...
                              X