Welcome Guest - Sign Up today
Welcome Guest - Sign Up today
Store Links Mobile - Shop Now

Announcement

Collapse
No announcement yet.

New Members - Welcome To The iBOATS Forum - Introduce Yourself And Say Hello

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • New Members - Welcome To The iBOATS Forum - Introduce Yourself And Say Hello

    Welcome to the Boating Forums sponsored by iBOATS.com, Your Trusted Source on the water.

    Say a few words about what you are looking for, need help with or just say hello. We will do our best to lend a hand.

    Thanks for joining the best boating site on the Internet.
    Since 1998, iboats is the most trusted water lifestyle online store for boat parts and accessories, boats for sale, and forums. Enjoy great priced products with fast shipping.
    BOAT SPECS FORUM HELP STARCRAFT FORUM SHOP iboats
    Please, no PM's (Private Messages) regarding boat/engine problems.
    That is what the forums are for.
    Only forum/moderator issues will be answered in PM's.

  • #2
    Hello guys im new to this site and have a question about winterizing the live wells on my 2013 tracker Pro V Guide 175. How do I drain the pumps and possibly add some rv antifreeze so the lines do not freeze.

    Comment


    • #3
      Did you figure out what the cause of the problem was? The exact same thing has happened to me from a motor I just bought. It's a 1977 Johnson 15 hp. When I open it up runs alright for a couple minutes then when I back half way-3/4 down it ****s off and very difficult to start back up. Carb clean kit work? Fuel pump?

      Comment


    • #4
      I didn't notice a new member introduction thread so thought I'd say hello here. I hope thats okay.
      About me, new to boating. I own a 1992 17' Bass Tracker with 25hp outboard and a 1986 Wellcraft 19.5' Elite 185 with the infamous 3.7 170hp inline 4 cylinder.
      Thanks for having me.

      Comment


      • #5
        Originally posted by Moberly bob View Post
        Hello guys im new to this site and have a question about winterizing the live wells on my 2013 tracker Pro V Guide 175. How do I drain the pumps and possibly add some rv antifreeze so the lines do not freeze.


        Hi Moberly bob

        Welcome aboard.

        The best place to ask is in the Boat Topics section where plenty of members will see the question and lend a hand - http://forums.iboats.com/forum/gener...-engine-topics
        Last edited by GA_Boater; October 25th, 2016, 12:31 AM.
        BOAT SPECS FORUM HELP STARCRAFT FORUM SHOP iboats
        Please, no PM's (Private Messages) regarding boat/engine problems.
        That is what the forums are for.
        Only forum/moderator issues will be answered in PM's.

        Comment


        • #6
          Doctor Hvac

          Welcome aboard, Doctor Cool.

          We do have an Intro thread. It's new and I'll this move into that thread.

          Sorry you have a 470 - Some of our members swear by them, others swear at them. LOL

          Originally posted by Doctor Hvac View Post
          I didn't notice a new member introduction thread so thought I'd say hello here. I hope thats okay.
          About me, new to boating. I own a 1992 17' Bass Tracker with 25hp outboard and a 1986 Wellcraft 19.5' Elite 185 with the infamous 3.7 170hp inline 4 cylinder.
          Thanks for having me.
          Last edited by GA_Boater; October 25th, 2016, 12:33 AM.
          BOAT SPECS FORUM HELP STARCRAFT FORUM SHOP iboats
          Please, no PM's (Private Messages) regarding boat/engine problems.
          That is what the forums are for.
          Only forum/moderator issues will be answered in PM's.

          Comment


          • #7
            Originally posted by GA_Boater View Post
            Doctor Hvac

            Welcome aboard, Doctor Cool.

            We do have an Intro thread. It's new and I'll this move into that thread.

            Sorry you have a 470 - Some of our members swear by them, others swear at them. LOL

            I'm used to it. Many swear by and adversely at the 6.0 diesel which original design flaw supposedly oil intercooler, head studs, etc.
            At an upgraded to 500 hp on that motor and now at 150k miles, zero issues.
            Im not here to hear about whether or not or who or who does not like the 3.7. Mines original at 30 years old and still running.
            Thanks for moving my post to correct section.

            Comment


            • #8
              Hey Doc - I'm not going to say anything bad about your 470. As long it works for you, that's all that matters.
              BOAT SPECS FORUM HELP STARCRAFT FORUM SHOP iboats
              Please, no PM's (Private Messages) regarding boat/engine problems.
              That is what the forums are for.
              Only forum/moderator issues will be answered in PM's.

              Comment


              • #9
                Originally posted by GA_Boater View Post
                Hey Doc - I'm not going to say anything bad about your 470. As long it works for you, that's all that matters.
                Not much anyone can say. Boat has new flooring with new carpet, new transom, all original 30 year old motor which has never had a major failure, just heard from boat mechanic cause im having a few preventative maintenance items addressed and upgrades (electronic ignition, fuel water seperator installed, etc.) and he can't believe how strong the boat and motor are, said its like new. He offered to buy boat, he can kiss it.

                Comment


                • #10
                  Trying to post pics but not much luck..

                  Comment


                  • #11
                    She sounds like a keeper, Doc.

                    Take a look at photo attachment guidelines here - http://forums.iboats.com/forum/forum...pload-tutorial

                    When you can get the pics to work, start a new thread to show off your boat in this section - http://forums.iboats.com/forum/gener...-engine-topics
                    BOAT SPECS FORUM HELP STARCRAFT FORUM SHOP iboats
                    Please, no PM's (Private Messages) regarding boat/engine problems.
                    That is what the forums are for.
                    Only forum/moderator issues will be answered in PM's.

                    Comment


                    • #12
                      Hello, I'm a new member and new to the boating world. I've started off rough here with an 87 Webbcraft with several problems, but this site has been invaluable. Shout out to everyone who takes their time to respond to questions and give input. That is what makes the internet such a wonderful thing !...and what allows a noob like me to enter the complex world of boat knowledge !

                      Comment


                      • #13
                        ATXastro.

                        Someday you will be helping from what you learn here. We have a bunch of good folks.


                        BOAT SPECS FORUM HELP STARCRAFT FORUM SHOP iboats
                        Please, no PM's (Private Messages) regarding boat/engine problems.
                        That is what the forums are for.
                        Only forum/moderator issues will be answered in PM's.

                        Comment


                        • #14
                          New guy here. Our family bought a vacation home in Lake Havasu, and I'm here doing some research before we buy our first boat.

                          Comment


                          • #15
                            Sign up today
                            Hi there, I'm working on my 1982 Evinrude 9.9hp outboard, trying to get it back to reliable working status. Will post some questions in a relevant forum. Cheers, Ingrid

                            Comment

                            Working...
                            X