• If this is your first visit to the iboats.com Boating Forums, be sure to check out the FAQ. To post a question or comment, begin by signing up. To start viewing messages, select the forum that you want to visit from the selection below.
  • ALL iboats Forum Members and Guests:
    To show our appreciation for your participation in the Forums, we're offering an exclusive Forums-only discount good for an additional 5% off your iboats.com order for a limited time.
    To redeem, simply call our Customer Service Team at 800-914-1123 (Open M-F, 9am - 8pm Eastern Time) and mention the Forums 5% off discount. Offer excludes engines, trolling motors, and electronics.

Announcement

Announcement Module
Collapse

Help Tip: If you have a question that has not been answered to your satisfaction in the archives, it is always best to start a new thread of your own. By starting your own thread, you will receive the maximum number of views by forum members.

Below are some additional forum policies in hopes of all iboats members will follow, Thank you.

1. Please do not reply to old threads or hijack existing threads. Old threads of a technical nature are like a library book, Please do not write in them.

2. Old threads should be considered archives and used for reference only. Please do not reply to them.

3. Do not take over someone elseís thread (aka hijack) with your own question, even if it is similar. If you have a question that has not been covered to your satisfaction in the archives, it is always best to start a new thread of your own.

4. If you have a question for the original poster (OP) and the thread is over 30 days old, send the OP a PM, he may not even visit the forums any longer, or may not notice your question in the old thread.

5. By starting your own thread, you will receive the maximum number of views by forum helpers that may not even notice your question when itís posted at the end of someone elseís thread. And those answers will be specific to your particular issue.

6. Please do not post to threads that have been inactive for more than 3 months unless you are the original poster. We have very active forums and any thread that remains inactive for that long should be considered "dead". It is especially confusing when there is an entirely new question posted to an old thread.

7. Posting at the end of any thread is considered to be hijacking the original posters thread which in turn subjects the thread to be closed if it continues to happen thus not making it fair to the original poster in the future had for some reason he/she needed to return for additional information or provide an update of the problem solved which is always welcomed within a reasonable amount of time frame.

8. Please note that you should see a red banner pop up near the bottom of each inactive thread asking you not to reply to old threads. The Red banner will read: Please note this thread has been inactive for 90 days. For the best results, please start a new thread.

Thank you all in advance for doing your part in helping iboats run a smooth ship.

Additional forum rules linked below.
http://forums.iboats.com/forum-rules-guidelines-405/
See more
See less

1979 50hp Mercury outboard

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts


  • 1979 50hp Mercury outboard

    I just bought a 1979 50hp mercury outboard. The engine worked fine when I fired it up but there isn't any water coming out of the engine. I think they call it the "telltale". I ran the engine for about 2 to 3 minutes and it shut off. The engine was hot. What should I do? Where is the telltale located on this engine? How do I replace or repair the pump? If there is anyone out there that can assist me, please respond. I NEED HELP!!!!


  • #2
    Re: 1979 50hp Mercury outboard

    the first thing to do is get a manual for your motor, it will help you out alot. you have to pull the lower unit off to change the impeller and that is the first thing you should do if its not pumping water

    Comment



    • #3
      Re: 1979 50hp Mercury outboard

      looking at your motor from the back, the telltale hose should be located at the top of the block with the hose hooked to a fitting on the block. sometimes the hose will get plugged up so check that too

      Comment

      Working...
      X