• If this is your first visit to the iboats.com Boating Forums, be sure to check out the FAQ. To post a question or comment, begin by signing up. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Collapse

Help Tip: If you have a question that has not been answered to your satisfaction in the archives, it is always best to start a new thread of your own. By starting your own thread, you will receive the maximum number of views by forum members.

Below are some additional forum policies in hopes of all iboats members will follow, Thank you.

1. Please do not reply to old topics or hijack existing topics. Old topics of a technical nature are like a library book, Please do not write in them.

2. Old topics should be considered archives and used for reference only. Please do not reply to them.

3. Do not take over someone elseís topic (aka hijack) with your own question, even if it is similar. If you have a question that has not been covered to your satisfaction in the archives, it is always best to start a new topic of your own.

4. If you have a question for the original poster (OP) and the topic is over 30 days old, send the OP a PM, he may not even visit the forums any longer, or may not notice your question in the old topic.

5. By starting your own topic, you will receive the maximum number of views by forum helpers that may not even notice your question when itís posted at the end of someone elseís topic. And those answers will be specific to your particular issue.

6. Please do not post to topics that have been inactive for more than 3 months unless you are the original poster. We have very active forums and any topic that remains inactive for that long should be considered "dead". It is especially confusing when there is an entirely new question posted to an old topic.

7. Posting at the end of any topic is considered to be hijacking the original posters topic which in turn subjects the topic to be closed if it continues to happen thus not making it fair to the original poster in the future had for some reason he/she needed to return for additional information or provide an update of the problem solved which is always welcomed within a reasonable amount of time frame.

8. Please note that you should see a red banner pop up near the bottom of each inactive topic asking you not to reply to old topics. The Red banner will read: Please note this topic has been inactive for 90 days. For the best results, please start a new topic.

Thank you all in advance for doing your part in helping iboats run a smooth ship.

Additional forum rules linked below.
http://forums.iboats.com/forum-rules-guidelines-405/
See more
See less

trim won't work, 2011 glastron mx185

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts


  • trim won't work, 2011 glastron mx185

    my neighbor just got himself a brand spankin new boat. zero hrs..
    it's got a mercruiser 190 hp v6, genII drive.

    he'd like to go boating but guess the dealer let him down.
    he took it to the lake the other day. he steered to starboard and the boat went to port. visa versa obviously. took it back to the dealer. they fixed that. but now the trim is inop. worked prior to the steering fix.
    surely they left a wire loose or something. w/o anything to go by and just looking. nothing just jumps out at ya as to what may not be connected. what fuses that look like possibility all appear good.

    any ideas as to which wire got removed when the steering was serviced?
    trim button is totally inop. no nothing... drive is up all the way..
    'Lime Time'
    1975 AristoCraft Nineteen
    Mercruiser 165hp (chevy 250 L6), MC-1 drive


  • #2
    Re: trim won't work, 2011 glastron mx185

    They (the dealer) should be open tomorrow! I can picture several different things. Mainly I'm thinking behind the dash. What does work, i.e. blower, bilge pump, nav lites, etc?

    Comment



    • #3
      Re: trim won't work, 2011 glastron mx185

      They (the dealer) should be open tomorrow!
      yep, neighbor says they are, but the time frame don't work with his work schedule.
      What does work, i.e. blower, bilge pump, nav lites, etc?
      every thing works except the tirm. neighbor says he tried everything else and all is ok other than the trim.
      Mainly I'm thinking behind the dash.
      me too. i'm on the assumption (i know, i know, if i'm wrong correct me) that the steering error was at the helm. therefor it was what was disassembled. a wire didn't get hooked back up inadvertently. that's my guess anyways. there are several wires free under dash but no easy apparently place to put the extra ones.
      'Lime Time'
      1975 AristoCraft Nineteen
      Mercruiser 165hp (chevy 250 L6), MC-1 drive

      Comment



      • #4
        Re: trim won't work, 2011 glastron mx185

        "Does't work" can mean a lot of things. Does it make any noise at all? If so, what kind? Clicks, groans, moans buzz. bang. Get the idea?
        Where is the trim/tilt switch located?
        Don S.

        sigpic

        Please, no PM's (Private Messages) regarding boat/engine problems.
        That is what the forums are for.
        Only forum/moderator issues will be answered in PM's.

        Comment



        • #5
          Re: trim won't work, 2011 glastron mx185

          That fiqures, that the dealer is closed.
          Test the pump to make sure it has power & ground. If not check battery connections. They usually miss a cable or 2. Start there, I'll ck back.

          Comment



          • #6
            Re: trim won't work, 2011 glastron mx185

            Does it make any noise at all?
            no.
            If so, what kind?
            it does nothing when the switch is energized, up or down.
            Clicks, groans, moans buzz. bang.
            nothing. silent. no power. imho.
            Get the idea?
            yep.
            Where is the trim/tilt switch located?
            at the top of the handle on the remote. like a 3000 i think. certainly not a 3000 though. rocker switch. up and down.

            That fiqures, that the dealer is closed.
            they're open. just 60 miles away + don't meet the owners work schedule demands.
            Test the pump to make sure it has power & ground.
            imho. it's missing one or the other.
            If not check battery connections. They usually miss a cable or 2. Start there,
            seems like a good idea. i'm confused by his batt. connections. there are extra wires that appear aftermarket. multiple connections at the batt. neg. and batt. positive. i wouldna thought that a brand new boat would have had clean pos. and neg. terminals. even my '75 is clean. 1 wire to ea. connection. his has multiple wires going to both. why, i don't know.
            'Lime Time'
            1975 AristoCraft Nineteen
            Mercruiser 165hp (chevy 250 L6), MC-1 drive

            Comment



            • #7
              Re: trim won't work, 2011 glastron mx185

              If installed by the book, Merc wants the trim pumps main wires attached directly to the battery. Many times the positive ends up on a switch, but the negative still needs hooked to the battery to work.
              Don S.

              sigpic

              Please, no PM's (Private Messages) regarding boat/engine problems.
              That is what the forums are for.
              Only forum/moderator issues will be answered in PM's.

              Comment



              • #8
                Re: trim won't work, 2011 glastron mx185

                Manufacturers never do the same thing as somebody else. Red is still positive (+). Black is ground (-) & so is yellow, as of 5-6 years ago. Look for 3-4 wires to (+). Big cable to starter, smaller heavy wire to trim pump, 1-2 small gauge like 14ga. Those 2 may have inline fuses wired into them. How many wires/cables are left?

                Edit; Check the plug at the pump itself. Round with 3 male spaes inside. Also the 20amp fuse in the J-clip.

                Don, I haven't seen to many manufacturers (boat) do anything "by the book" for 30yrs!

                Comment



                • #9
                  Re: trim won't work, 2011 glastron mx185

                  Don, I haven't seen to many manufacturers (boat) do anything "by the book" for 30yrs!
                  I have, actually most of the time. Where things change is when the buyer wants extra batteries, or a switch, or ......... then things start changing with what the dealer does.
                  Don S.

                  sigpic

                  Please, no PM's (Private Messages) regarding boat/engine problems.
                  That is what the forums are for.
                  Only forum/moderator issues will be answered in PM's.

                  Comment



                  • #10
                    Re: trim won't work, 2011 glastron mx185

                    I totally agree! But when a pays the better part of 30K for a boat that steers backwards! I thought I would start with the basics!

                    Comment



                    • #11
                      Re: trim won't work, 2011 glastron mx185

                      That starts at the manufacturer. they installed the steering.
                      Shame on the dealer for not checking all systems prior to deliver,
                      and shame on the buyer for not taking a trial run with the dealer to learn the boat and make sure it works.
                      and shame on the buyer for not taking a test run before buying a boat.
                      Don S.

                      sigpic

                      Please, no PM's (Private Messages) regarding boat/engine problems.
                      That is what the forums are for.
                      Only forum/moderator issues will be answered in PM's.

                      Comment



                      • #12
                        Re: trim won't work, 2011 glastron mx185

                        I hope he responds to the CSI survey's "Honestly"! And make things uncomfortable for the dealer!

                        Comment



                        • #13
                          Re: trim won't work, 2011 glastron mx185

                          thanks for the ideas. if i see the neighbor out with his cover off this morning i'll go down and see what we can find.
                          looks like the neighbor might not need his boat today too.
                          looks like rain,.
                          40% chance of rain,.

                          i think i'll go and prep my boat for going out.. watching for rain to ruin my day.

                          if it rains today, the neighbor can take it to the dealer tomorrow and let them uncluster it i guess...

                          fwiw. the attachment looks very much like what he may have. trim pump looks the same, remote looks the same, except his is side mount. solenoids look similar..
                          Attached Files
                          'Lime Time'
                          1975 AristoCraft Nineteen
                          Mercruiser 165hp (chevy 250 L6), MC-1 drive

                          Comment



                          • #14
                            Sign up today
                            Re: trim won't work, 2011 glastron mx185,(resolved)

                            well, turns out there was a vital (imho) piece of info that we didn't have.

                            the remote had been removed to service an inop hr meter which is located right next to the remote.
                            the trim wire disconnect plug right behind the remote was not reinstalled when the remote was put back after the hr meter repair..

                            neighbors getting happier by the min. i think...

                            thanks again for the help..

                            ps. i made it to the lake yesterday only to get monsooned on for three hrs prior to giving in to the bad weather. now i gotta clean up my disaster after coming home on wet pavement.. wet, soggy, filthy boat now... only thing i'll say good is that it was better than not going boating at all. but not by much..
                            'Lime Time'
                            1975 AristoCraft Nineteen
                            Mercruiser 165hp (chevy 250 L6), MC-1 drive

                            Comment


                            Working...
                            X